Asterisk + Linksys WRT54G + xlite... Pls help!


#1

Greetings,

Quick overview:
LAN works but not WAN.

My setup:

  1. Asterisk@Home 1.5
  2. Linksys WRT54G with latest firmware
  3. Comcast Cable
  4. xTen Lite
    Not related to my problem (I think):
  5. OEM Digium X100P Modem Card

Problem:
I can call from one extension to another using xlite softphone outside my network (i.e From work/hotspot). It registers, logged in, dials and rings… but once “Connected” I don’t get the Audio or Voice from both ends. But this works perfectly if I do it inside my network at home.

My xlite configuration:
SIP Proxy > [Default]:
Enbled: Yes
Display Name: Mr. Two Hundred
Username: 200
Authorization User: 200
Password: xxxx
Domain/Realm: my.comcast.ip.adr
SIP Proxy: my.comcast.ip.adr
The rest are default…

What I have tried:

  • Enable DMZ on my WRT54G
  • Disable Firewall on my WRT54G
  • Add “canreinvite=no” on sip.conf (and vice versa “canreinvite=yes”)

I would really appreciate it if you experts can help.

Thanks


#2

You’re going to need to setup a lot of port forwarding to your Asterisk box in the Linksys box.

All of the packets you’ll want to forward are UDP.

Check this page for a list of the ports that you should forward to your Asterisk box.

voip-info.org/tiki-index.php … wall+rules

I don’t know if your Linksys box will support more than one “outside” connection at a time, but it might…

This page has a very good step-by-step how-to for firewalls.

automated.it/asterisk/lah-3-6-05_5.html


#3

Hey dufus,
Thanks for the reply. I am getting a better understanding now. Based on the 2 links/websites you provided. It leads me to believe my problem is the Linksys Router.

Question:
My Linksys WRT54G is also my all-in-one router. It has port fowarding, DMZ, firewall, etc…
Do I still need to do port fowarding if I “Enable DMZ”?

Really appreciate your help.

Thanks


#4

I use Asterisk with a WRT54G and do port forwarding. I recommend this over DMZ, as it is more secure and you may control things a bit better.

As an interesting aside you can run Asterisk on the WRT54G:

voip-info.org/wiki-Asterisk+Linksys+WRT54G

Have not done it myself, but…


#5

Is there anyone that has the same setup like mine and work it to work over WAN?
My setup:

  1. Asterisk@Home 1.5
  2. Linksys WRT54G with latest firmware
  3. Comcast Cable
  4. xTen Lite
    Not related to my problem (I think):
  5. OEM Digium X100P Modem Card

If yes, can you kindly post your step by step installation/configuration???

Thanks