Asterisk from source: ExecIfTime exists but ExecIf missing


On a Debian Bookworm host, I’m compiling Asterisk from source.
As the Ansible playbook I’m using for this is quite long, I won’t quote the exact steps I followed.

Anyway, after running my playbook, I can see that Asterisk is running but though application ExecIfTime is present, application ExecIf is missing.

I tried with several Asterisk versions (20.4.0, 20.2.0 and 16.30.1) and got the same result.
I’m quite confident it comes from an issue in my script, maybe a missing dependency, but I don’t know where to look out first.

I ran “make mesuselect” and saw “app_exec” is present (and app_exec.* files are present and recent).

Any clue ?

Best regards

ExecIfTime is a core dialplan application. ExecIf is from app_exec as you’ve stated, it has no extra dependencies. You didn’t state whether the file exists in the modules directory, and if so - is it loaded in Asterisk? If not and it exists what happens if you manually load it?

Right on spot: my playbook used “make basic-pbx” which includes a reduced list of modules and app_exec was not among them !!

Thank you very much for replying and sorry for such a “basic” question from me.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.