ExecIF no longer avaliable in 16.4?

I’ve tried searching this issue on google, but not much. I am upgrading my Asterisk 11.3 to 16.4 (yes I know, big jump, have not touched this server for MANY years, is it working why try to break it.)

Anyway, I am getting this error when the call process:

WARNING[1569][C-00000001]: pbx.c:2922 pbx_extension_helper: No application ‘ExecIf’ for extension…

And when I run "core show applications, I didn’t see the function ExecIF (I do however see ExecIfTime).

So what happen to ExecIF? Am I just too far out of touch with the newer Asterisk?

Thank you!

It is part of the app_exec module. Is that module loaded?

1 Like

You are awesome!

thank you very much. Under the documentation, is there a place where I can see where these “function” is under what “module”?

The asterisk documentation page doesn’t seem to show that


Now I am getting that the application “While” is not avalible, so wonder where that module is under…

Thank you!


I don’t think there is a list as such, I just found it by using grep through the source code. While is under app_while.

Ok, yes, I found it by just eye ball all the module. Thank you very much. I will try your method.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.