Asterisk.ctl does not excist


I have installed asterisk 1.6.1-rc1 with the addons 1.6.1-rc2 and mysql
Till i install ./install_amp from freepbx asterisk CLI works perfect.

I looked where my asterisk.ctl is located and that is /var/run/

Now when i don’t change the asterisk.conf and run ./install_amp and after that i run amportal start i get an error.

astrundir in /etc/asterisk/asterisk.conf is set to ‘/var/run’ - THIS IS WRONG.

When i change the asterisk.conf --> pico /etc/asterisk/asterisk.conf
astrundir => /var/run to astrundir => /var/run/asterisk

And run ./install_amp it amportal works perfect but i can’t use asterisk -r. I get the error does asterisk.ctl excist.

Now it is strange to me that i must change the asterisk.conf to /var/run/asterisk because asterisk.ctl excist in /var/run/ :open_mouth:

I tried to figure it out and i don’t get it why it won’t work. Please help me!

Thnx for your time

Strange we have solved the problem!!!

Wenn we started the server we also did Amportal start. See this script.

pico /etc/rc.local
insert above the “exit 0” line
amportal start
save and quit

Now we first start asterisk and then start amportal and that works fine!!
Like this:

pico /etc/rc.local
insert above the “exit 0” line
asterisk start
/usr/local/sbin/amportal start
save and quit

I hope other people have somenthing with this solution!!