Asterisk crashes after leaving voicmail and others

Hi there everybody,

I have asterisk running on 3 servers. The latest one has 1.4 version others are old. One is just using for calling card platform. the other one including new one will be served for pbx system. The older one did not have any issue on this heading but the new one has it.
I can create voicemail, i can see message indicator and read it accept
after leaving message when # key pressed or just hung up asterisk crashes with the last comment " segmentation fault (core dumped)"
I have to restart asterisk -vvvvvvvgc with this command and listen the message. Can anyone give a solution of this?

Other problem is when someone dial an extension after greeting and if you alredy know the xtention plz dial it now after the prompt i dial 200 the extention and after a long time the target extention rings where it suppose to ring instantly when i dial the ext and it was working fine before . How can i get to fix it to instant ringing?

One more thing i cannot dial while greetings and other prompt playing
what is the way to dial the exten while in the middle or beginning of the
prompt so that i dont need to wait untill it finish and take my dialed exten
it must be similar to barge in but could not find it can any one give solution of these 3 problems??


the core dump generates a file .core you need to debug it, i don’t know there can be billions of reason… maybe he cannot write into the directory for voicemail… and it panics…

and maybe you need to post your dialplan too, yes it should ring immediately, show us some log and the dialplan maybe we can help more :smile:

Hi cavicci ,

Thanks for reply and hope you can walk me out of this problem.
How will i debug .core file?
First here is my CLI log after leaving my voice message

– Recording the message
– x=0, open writing: /var/spool/asterisk/voicemail/default/555/tmp/HGYkRh format: wav49, 0x255ac00
– x=1, open writing: /var/spool/asterisk/voicemail/default/555/tmp/HGYkRh format: gsm, 0x255a7c0
– x=2, open writing: /var/spool/asterisk/voicemail/default/555/tmp/HGYkRh format: wav, 0x2560800
– ast_get_srv: SRV lookup for ‘’ mapped to host, port 5080
– User ended message by pressing #
– <SIP/> Playing ‘auth-thankyou’ (language ‘en’)
Segmentation fault (core dumped)

If it cannot write into the directory of voicemail than how come i can read it through my extention?

this is my extensios.conf dial plan


exten=>2146142523,4,Background(welcome_8) // here i ws using playback now i can dial in the middle of greetings so problem 3 is resolved i think but still it takes long time after dialing the target extension that means prob 2 exist //

exten=>2146142523,5,Background(ex_kn) // '"" //



waiting for your response.

it’s cavicchi :stuck_out_tongue:


i don’t know what operative system you are running, anyway, check online what u have under ur OS

i run freebsd and ktrace is pretty comfortable ktrace XXX and then kdump to see my error…

you just dial 2000 and wait?

write down the cli output for that

do you need to transfer the call? that’s why u use tT? can you just use gm or m ?

g is for letting the caller keep going down in the dialplan if you hang up
m is for music on hold while calling

maybe its the parking… try

mmm i think the problem is related to the voicemail…


i see "Playing ‘auth-thankyou’ "
do you hear that message?

make sure to configure correctly the voicemail at the beginning


forcename = yes ;so you will configure your voicemail at the beginning
forcegreeting = yes


206 => 206,Matteo,,attach=yes ;same user and password so asterisk will understand that u need to configure it.

tell me the output of those 2 commands when asterisk is running

ps aux | grep asterisk
ls -la /var/spool/asterisk/

and maybe check the ‘top’ command while contacting voicemail to see if there is a peak of memory

Hi cavichi,

Step by step i answer ur question.
my OS is fedora core 8 & asterisk1.4

I wrote down the cli output for dialing 200 exten no and where exactly
crashing also logged.

Ya ia am trasferinsg the call when i need it. tT works fine i tried with gM
not worked.

Playing “auth-tahnk-you” yes i hear that message after pressing # key
and astreisk crasshed.

force… =

where put this info in voicemail.conf?

I am saving the voicemail as


and in exten.conf
its already their in my previous post

plz help me out pin point this problem