Asterisk Channels not Closing from sipp

Good day,

I have this issue when testing my asterisk ARI application with sipp testing tool. When i start the sipp command to begin the test ,I am receiving 100 calls on asterisk server but the problem is the channels are not being closed. The channels are all in ringing state and not closing until i restart the asterisk server. Anyone familiar with this problem please help me.

Asterisk CLI after using “core show channels”:

PJSIP/sipp-00000002 44444@for_everyone:2 Ring Stasis(Intro-IVR)
123 active channels
100 active calls
100 calls processed

SIPp defines the precise scenario of SIP messages. You have to look at the scenario and what you are testing, and then determine who is supposed to hang up or terminate the call. For example if you are using a scenario that is waiting for a call to be answered and your ARI app doesn’t do so, then it won’t continue, and it won’t hang up.

SIPp provides example scenarios and documentation on their website.

Hi jcolp,

Currently i am using a default scenario “-sn uac” in order to do my testing, I guess from what you are saying is that the default scenario does not have BYE to hangup the calls. I thought this wouldn’t matter as in my ARI app i am terminating all channels in StasisEnd event when i do a normal call but when i am doing a sipp test i found out through debugging that it is not reaching the StasisEnd event hence nothing is hanging up the calls. I tried using a custom scenario to see if i get the same issue but for some reason i get this error when i run the sipp command. Please do you have any knowledge of this error.

./sipp -sf /Home/Downloads/scenarios/sipp_uac_pcap_g722a.xml -s 44444 asterisk ip address -l 100 -r 10 -trace_err -error_file sipperror


Unable to load or parse ‘/Home/Downloads/scenarios/sipp_uac_pcap_g722a.xml’ xml scenario file.

StasisEnd is called when the channel leaves your ARI application. It has to either be ejected from it, or hung up. If nothing is hanging it up, then it will remain there.

As for the SIPp error you’d have to investigate and see if there’s malformed XML, or if it is failing for some other reason. Narrow down the issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.