Asterisk can't find sound file

I’d like to change the voicemail password prompt. I have edited voicemail.conf as follows:

; Customize which sound file is used instead of the default
; prompt that says: “password”

These sound files exist:
ls /var/lib/asterisk/sounds/en/pls-enter-vm-password.*

However, when I try to access my voicemail, asterisk complains that the files do not exist:

-- <SIP/60-0822aba8> Playing 'vm-login.ulaw' (language 'en')

[Apr 6 12:11:45] NOTICE[9458]: sched.c:221 ast_sched_add_variable: Scheduled event in 0 ms?
[Apr 6 12:11:49] WARNING[9458]: file.c:587 ast_openstream_full: File custom_sound=pls-enter-vm-password does not exist in any format
[Apr 6 12:11:49] WARNING[9458]: file.c:896 ast_streamfile: Unable to open custom_sound=pls-enter-vm-password (format 0x4 (ulaw)): No such file or directory
[Apr 6 12:11:49] WARNING[9458]: app_voicemail.c:6895 vm_authenticate: Unable to stream password file
– Executing [500@phones:2] Hangup(“SIP/60-0822aba8”, “”) in new stack
== Spawn extension (phones, 500, 2) exited non-zero on ‘SIP/60-0822aba8’

Help would be appreciated!


PBX Core settings

Version: 1.6.0-beta7.1
Maximum calls: Not set
Maximum open file handles: Not set
Verbosity: 5
Debug level: 0
Maximum load average: 0.000000
Minimum free memory: 0 MB
Startup time: 11:26:46
Last reload time: 11:26:46
System: Linux/2.6.24-1-686 built by root on i686 2008-04-02 20:37:34 UTC
System name:
Default language: en
Language prefix: Enabled
User name and group: /
Executable includes: Disabled
Transcode via SLIN: Enabled
Internal timing: Disabled
Transmit silence during rec: Disabled

  • Subsystems

    Manager (AMI): Disabled
    Web Manager (AMI/HTTP): Disabled
    Call data records: Enabled
    Realtime Architecture (ARA): Disabled

  • Directories

    Configuration file:
    Configuration directory: /etc/asterisk
    Module directory: /usr/lib/asterisk/modules
    Spool directory: /var/spool/asterisk
    Log directory: /var/log/asterisk

Have you re-started asterisk after the changes? As I think a reload won’t do the trick.

Yes - I have rebooted the host machine. No joy :frowning:

Update: I have reverted to version 1.6.0-beta5 of Asterisk, and this works correctly. :confused:

Have you checked ownership of the files? I have had this problem at times. Check the files and folders ownership, asterisk:asterisk or at least chmod 644.

Thanks for the suggestion, but the files are all ok (and I’m runnning asterisk as root to avoid that type of problem - it’s a test system.)