Asterisk Calls being half-dropped


#1

Hi,

I have a strange situation where after anything from 10-25 minutes, I can no longer hear anything from the other party on my call, but they can hear me just fine. It never recovers, I need to hang up. I usually have to say “I lost you, call me back”. Weird huh. They can usually call me right back just 2 seconds later no problem and then we have again 10-25 minutes before it re-occurs. On a one hour conference call I usually end up having 3 such dropouts.

The configuration:

Asterisk server running in New York at my employers. There’s only 1 IP phone connected to it, mine. My phone is at home here in Germany. It’s connected to my router which keeps my DSL connection alive 24/7. It only is forced to renew the DSL lease once per day and that never happens during the call because I force the renew as soon as I wake up so that it’s done on my terms and not when I’m not expecting it.

Our IT department in NYC aren’t VOIP experts but they’re very good. They say they see no problems with the line during one of these one-way dropouts. Network traffic is light usually, ping responsiveness is reasonable (under 200ms) and all looks good. They HEAR me perfectly during a half-dropout.

On my side I’ve port-forwarded all the ports the IT department told me to on my router to the phone (5060 and 10000-10015 UDP). I’ve disabled the DoS attack defense functionality of the router, I’ve even tried setting the phone’s IP as a DMZ host.

It seems like it would probably be something at my end but I’m out of ideas. There’s so many options in my phone that to list them all would probably be pointless as I imagine only a handful would be relevant. I’m using SIP (not IAX) and the phone is a noname chinese model, but I had the same problem with a Grandstream BT100. The config pages for the phones are totally different but somehow the problem persists across both. That leads me to think it’s something outside the phone.

If I can’t get an answer here I’m tempted to try (the surprisingly difficult with my router config) configuring the phone to get the PPPoE DSL connection itself (which it’s capable of) thus bypassing my router. If that doesn’t work then it must be either my ISP or really something at my employer’s end.

Anyone have ideas?


#2

Nobody here knowledgeable about Asterisk troubleshooting?


#3

is there a NAT on your employer’s side? if so, how are they set up for port forwarding.

also, your RTP port range is extremely small - by default, asterisk uses ports 10000-20000 for RTP signalling, so the 15 port range you have might need to be increased.

if the server is not behind a NAT and has a public IP, you might try bypassing your router and getting a public IP as well - if the phone works the, you know it’s a NAT issue on your end.

sorry i can’t be of more help - we mucked around with a similar issue for 3 weeks with one of our remote users - we ended up just having her go over the VPN in the end - nothing we did made it work.

good luck.


#4

Sec…lemme calc…
Could be an re-invite… the phonecall is longer then the usual register refresh value…

Just loud thinking.

Anyway, you need to open not only 5060, you need 5060-5063
for SIP.

Try opening 5060-5063 and then stopwatch the dropout time and check if it matches the refresh registration timespan.

TO do this, make the call to New York RIGHT AFTER you re-registered the telephone to asterisk.

Now you should start your stopwatch same time and make the call.
If the drop happens exactly when the re-register/invite is happening…voila.

Is the asterisk CLI saying
"Native bridge between…"
or is the call DIRECTLY between your two phones ?

The native bridge would cause a different behaviour (register and invites) then an unbridged call.


#5

Thanks guys, those sound like some great suggestions. I’ll get onto that as soon as New York wakes up :smiley:

edit: I made the port changes on my router (opened 5060-5063 instead of only 5060, and opened 10000-20000 instead of only 10000-10015). I forwarded your messages to our MIS dept.

Waiting now to see if any of those suggestions help them figure out the problem.


#6

WUD ?!

NVC never sleeps… :stuck_out_tongue:


#7

OK, found out some things. They told me that they only have port 5060 and 10000-10015 open, so my router settings were correct. They DO have a public IP address for the asterisk server. They’re considering opening more ports but they thought that was enough.

They also said “Not a re-invite problem - there’s no native bridging going on - it’s analog to SIP.”. The deal is, I’ve got a desk at NYC for when I’m there, and a phone number naturally. If anyone inside the NY office dials my extension number, it goes through asterisk and across the atlantic to me here. So if they have extension 123 to their left, they get them. If they dial 456 to the right (my empty desk) it is routed here to home. Likewise, if I pick up my phone here at home it’s exactly as if I was picking up a physical phone in NY. I can dial 3 digit inner office extensions or 1-xxx-xxxx-xxxx outside lines. Not sure if any of this makes a difference but knowledge is power :wink:

So currently there are only two things to try:

  1. They open more ports.
  2. I try direct, bypassing my router.

Does this update trigger any more thoughts?


#8

You can even do it easier (i am using an “outside” phone too, miles away). I even use my PDA in a hotel to log into asterisk on my extension :stuck_out_tongue:

Have ONE extension but define it like this:

exten=> 123,1,dial(SIP/123&SIP/456)

That way always both phones are ringing !
Put one on “DND” if you dont want to have it ringing.

For the problem:
Ok…lets think loud:
One side going away means, RTP paket loss (UDP)
Your packets still outgoing (NAT Router i guess) but packets incoming are rejected.

Is there a log in your router you could check ?


#9

Problem appears to be solved. I’ve switched from my Hama router (Hama is a german manufacturer that makes these cheap little piece of garbage) to an old SMC Barricade that I’d retired.

With the Hama router, the call gets half-dropped after anything between 5 minutes and an absolute maximum of 25 minutes. I never had a call last longer than 25 mins.

With the SMC Barricade I’ve had two calls since I switched router.
One for [size=150]94[/size] minutes and one for [size=150]130[/size] minutes so far.

Thanks for your suggestions guys.