I have Problems with Asterisk


I have problems with Asterisk to listen to the correct port. It listens to port 2000, and it will listen to port 5060. I have changed this in sip.conf but nothing happens.

Nor is there anything running on port 5060

You sure it’s not the port 2000 configured in skinny.conf?

If you set the bindport in sip.conf to 5060 and reloaded Asterisk afterwards then it should be port 5060.

Tnx for the fast feedback.

It’s 2000 on the port in skinny.conf Should it be 2000 at the port where or should I change it to 5060?

What I meant is that the port 2000 you pointed out Asterisk was listening might be the one in skinny.conf

Could I make you do following:

asterisk -r

asterisk*CLI> sip show settings

Then copy+paste the output here.


I try this command

asterisk -r

Error: cannot execute binary file

And i try this command

asterisk*CLI> sip show settings

Error: -bash: asterisk*CLI: command not found

There we have it :wink:


Is there anything that might be blocking port 5060? any firewall? Seeing as your SIP peers can’t connect.

You can do a ‘sip show registry’ in the Asterisk CLI to see the state of your SIP registrations, along with ‘sip show peers’ to see if there is any clients connected to your Asterisk.

You can also have a look in /var/log/asterisk/messages to see if you can spot any easily spotted errors?


No there is nothing in firewall that blocking port 5060.

For i have test FreeSwitch platform And it was on port 5060

Print from /var/log/asterisk/messages

[quote][Jun 29 05:19:23] WARNING[18970] chan_sip.c: Failed to bind to Address already in use
[Jun 29 05:19:23] WARNING[18970] chan_iax2.c: Unable to open IAX timing interface: No such file or directory
[Jun 29 05:24:47] NOTICE[19174] cdr.c: CDR simple logging enabled.
[Jun 29 05:24:47] NOTICE[19174] loader.c: 146 modules will be loaded.
[Jun 29 05:24:47] WARNING[19174] res_smdi.c: No SMDI interfaces are available to listen on, not starting SMDI listener.
[Jun 29 05:24:47] NOTICE[19174] pbx_ael.c: Starting AEL load process.
[Jun 29 05:24:47] NOTICE[19174] pbx_ael.c: AEL load process: calculated config file name ‘/etc/asterisk/extensions.ael’.
[Jun 29 05:24:47] NOTICE[19174] pbx_ael.c: AEL load process: parsed config file name ‘/etc/asterisk/extensions.ael’.
[Jun 29 05:24:47] NOTICE[19174] pbx_ael.c: AEL load process: checked config file name ‘/etc/asterisk/extensions.ael’.

Thanks for your help. I tried to contact the server with a SIP client and it works.

Hehe, ok. Great you got it working. :smile:

Do you have any experience with freepbx?

I have very little experience with FreePBX, I tried it once.

I like Asterisk alot more, I think you are more free to do what you want, but it’s been quite a while since I tried.

Ok, For I need a webinterface. Do you know someone who is easy to set up?

I installed FreePBX once, and it was a OS on it’s own, which I installed from a dvd.

It had a running webinterface by default when I installed it, so yours might aswell?

I have a small problem to. I can not be called
internally. It’s just

in my sip client. What can be wrong

Did you setup just the SIP user?

You must configure in extensions.conf what to do when extension ‘500’ is called, or whatever your SIP user is called.

An example from my own configuration (Modified for your understanding)


include => direct

exten => 500,1,Answer
exten => 500,2,Set(CALLERID(name)=Direct)
exten => 500,3,Ringing
exten => 500,4,Dial(SIP/500)[/code]

The reason I’ve used the first context to include the direct call macro, is because in SIP.conf my context is default.


[general] context=default

Try to play around with that. You might want to read


Just the site http://www.voip-info.org is a very great source of information regarding Asterisk.

Ok, Tnx :smile:

But back to the Webinterface. I’ve tried to install freepbx. But I can not install the amp (Amportal). It appears that it can not find the file when trying to download it.

Do you know any places i can download it from?

Have you tried to install it by CD? I mean download the trixbox ISO file and burn onto a disk.

No i have not tried that. I can not install it with cd. For my server is a completely different place.

Oh, I see. That would make quite a challenge I suppose. :wink: