Asterisk 13.1 Startup Failed - Please Assist

After attempting an install of Asterisk version 13.1 on a VM running CentOS 6.6 following the guide at, I received the following “Illegal Instruction” error after the “extconfig.conf” was loaded. Are there any ideas as to what I can do to resolve this error?

To diffuse the tension associated with this error, the following smiley faces have been included to ease both of our suffering: :smiley: :cry:

The output of my terminal window is included below for reference:

[root@itec-rtc certified-asterisk-13.1-cert2]# rasterisk
Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)
[root@itec-rtc certified-asterisk-13.1-cert2]# asterisk -cvvvvvvvv
Asterisk 13.1-cert2, Copyright (C) 1999 - 2014, Digium, Inc. and others.
Created by Mark Spencer <>
Asterisk comes with ABSOLUTELY NO WARRANTY; type 'core show warranty' for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type 'core show license' for details.
[ Initializing Custom Configuration Options ]
  == Parsing '/etc/asterisk/extconfig.conf': Found
Illegal instruction

You will need to rebuild Asterisk without BUILD_NATIVE enabled. This can be done by going into the source code directory and executing “make menuselect”. In menuselect go to “Compiler Flags - Development” and uncheck “BUILD_NATIVE”. Save and exit menuselect. Once done do “make && make install”. This should give you a working Asterisk.

The underlying reason this is happening is because the compiler is trying to optimize things for the native CPU. Unfortunately in your virtualized environment this doesn’t work correctly and it ends up trying to use stuff which is unavailable.


I just want to confirm this solution
i have AMD ryzen 1700x processor and build asterisk 13.18 in vmware Workstation environment in starting asterisk i got Illegal instruction like above after unchecked BUILD_NATIVE problem was solved,
thank you man.