Asterisk 11 auto-pause problem

I have installed asterisk 11.2.1 and freepbx 2.11,
I tested auto-pause with queue and it worked will for busy and unavailable agents,
but i have a problem in case of busy status, agent continues paused after hanging the calls so it can’t receive more calls from the queue !

how can i auto-UN-pause the agent after hanging the call to receive another one?

You are going to have to provide information about how your agents are configured. I suspect that the queue system is seeing an inuse, or unknown status, rather than a busy, so thinks the queue member could answer immediately.

My agents are configured as “Static Agents” for this queue,
please note that after the agent finishes a call, he must dial “*46” for Queue Pause Toggling and receive more calls. How can i do this toggling automatically?

it is a copy from my queue configuration:

Actually, they are indirected via Local channels. That means that you will not have any device status before the call is attempted. That might be enough for the problem. However, the next question is what steps have you taken to get a proper busy status at the device level (e.g. call limits) and what does the local channel code do to ensure that queue application sees busy, rather than, say congestion.

Dear Mr.David,
from asterisk logging i found:

[quote]-- Local/500@from-queue-0000003d;1 is busy
– Nobody picked up in 0 ms
– Auto-Pausing Queue Member Local/500@from-queue/n in queue 30 since they failed to answer.

i have made a call limitation on extension 500 by disabling “call waiting” feature on this phone.

I would definitely change the ringinuse setting, but I’m not hopeful that it will help.

This may simply be a mis-feature, which you will have to work round with AMI.