Asterisk 1.8 + Gui rev 5117 Loop

I recently installed Asterisk 1.8 on an EC2 Centos5.5 server via yum. Everything looks to be working fine with the core, but I’m also attempting to install the Asterisk 2.0 GUI and running into a loop issue. The install was done via the latest SVN trunk (5117) and the make checkconfig says everything is fine in my manager.conf and http.conf files. I can get to the site with no issues, login fine, however when I login I go through a loop of:

Verifying dialpad context needed for GUI
Checking write permission for Gui Folder
Checking hardware configuration
Taking backup of current configuration
Upgrading configuration

I’ve given the static-http folder all of the appropriate permissions and I’ve tested in Chrome, Firefox and IE. Chrome and Firefox both have the loop. IE just displays HTML. The HTML does state that the rev is 5116. I tried to uninstall and remake using 5117 to ensure I had the latest version and it does confirm I have 5117, but the GUI doesn’t update it’s rev.

Any thoughts on what I can do to stop the loop and move forward? Are there conf files I can show to help identify the issue?

Thanks,
Doug

Just my opinion, skip the GUI …

I have the same problem with centOS 5.5 and asterisk 1.8 and yum installation ( yum install asterisk-gui) . I try to find the solution. infinit loop in firefox and html code in explorer. I try without sangoma driver but same result.

I assigned the permissions to the below list of folders as shows, it fixed my issue.

sudo chown -R asterisk:asterisk /var/lib/asterisk/
sudo chmod -R 777 /var/lib/asterisk/
sudo chown -R asterisk:asterisk /etc/asterisk/
sudo chmod -R 777 /etc/asterisk/

Note: Just make a note of previous folders’ permissions before applying these all changes.

World write on /etc/asterisk, and possibly on /var/lib/asterisk sub-directories is a hackers charter. Some daemon software will actually refuse to run if you do that sort of thing to its configuration directories.