Asterisk 1.6 inbound calls problem

Hi, i have a very strange problem with asterisk
i upgraded from 1.4 to 1.6, and i can’t get inbound calls working
it seems that asterisk is registered without problems:

igniqi*CLI> sip show registry
Host Username Refresh State Reg.Time 0240xxxxxx 105 Registered Thu, 22 Jan 2009 12:00:16 0240xxxxxx 105 Registered Thu, 22 Jan 2009 12:00:16 0240xxxxxx 105 Registered Thu, 22 Jan 2009 12:00:16
3 SIP registrations.

igniqi*CLI> sip show peers
Name/username Host Dyn Nat ACL Port Status 5060 OK (30 ms) 5060 OK (29 ms)
2 sip peers [Monitored: 2 online, 0 offline Unmonitored: 0 online, 0 offline]

but when i call these numbers i can’t hear nothing
i tried to debug the problem, and even with high debug/verbose i coudn’t get any message at all, so i tried tcpdump and no traffic is coming to my asterisk server at all!!!
i stopped iptables, and still nothing, plus the same port configuration with 1.4 was working, so it’s unlikely a not asterisk related misconfiguration
outbound calls works fine
how can i debug this problem? it’s possible that the state say Registered but it’s not registered at all?
TIA, Federico

i tried to register with another provider, same problem :frowning:
the provider page too says i’m registered, but absolutely no traffic incoming when calling the assigned geographic number .

i found a problem
if i bind the server on port 5060, works
port 5061, doesn’t work

same config and same firewall works with 1.4
this seems weird

Someone told me that 1.6.0 had a port binding bug when SIP was set to anything other than 5060 - this may have been TCP/5060 though. And this was in December it got told to me.

You may want to look through the bugs.