Asterisk 1.6 + asterisk GUI 2.0


I do apologise if this is in the wrong area.

However over the last week i’ve been stuck on this problem and i have tried many differnt solutions to the problem, and really do need some advice or a little nugde in some direction.

I’m installed asterisk 1.6 no problems
but i didn’t realise it came without the web GUI.

so after researching abit and finding ASterisk Web GUI2.0 i was delighted, downlaoded and install, and then configured the Http and manager files as shown below.

[http file]
; Asterisk Builtin mini-HTTP server
; Note about Asterisk documentation:
; If Asterisk was installed from a tarball, then the HTML documentation should
; be installed in the static-http/docs directory which is
; (/var/lib/asterisk/static-http/docs) on linux by default. If the Asterisk
; HTTP server is enabled in this file by setting the “enabled”, “bindaddr”,
; and “bindport” options, then you should be able to view the documentation
; remotely by browsing to:
; <server_ip>:/static/docs/index.html
; Whether HTTP/HTTPS interface is enabled or not. Default is no.
; This also affects manager/rawman/mxml access (see manager.conf)
; Address to bind to, both for HTTP and HTTPS. Default is
; Port to bind to for HTTP sessions (default is 8088)
; Prefix allows you to specify a prefix for all requests
; to the server. The default is blank. If uncommented
; all requests must begin with /asterisk
; sessionlimit specifies the maximum number of httpsessions that will be
; allowed to exist at any given time. (default: 100)
; Whether Asterisk should serve static content from http-static
; Default is no.
; Redirect one URI to another. This is how you would set a
; default page.
; Syntax: redirect=
; For example, if you are using the Asterisk-gui,
; it is convenient to enable the following redirect:
;redirect = / /static/config/cfgbasic.html


( i’ve left the https out at the bottom as i’m just trying to get this sorted first :smile: )

and the manger file
[[i]manager file]
; Asterisk Call Management support

; By default asterisk will listen on localhost only.
enabled = yes
webenabled = yes
port = 8088

secret = 123456789
read = system,call,log,verbose,command,agent,config,read,write,originate
write = system,call,log,verbose,command,agent,config,read,write,originate
; No access is allowed by default.
; To set a password, create a file in /etc/asterisk/manager.d
; use creative permission games to allow other serivces to create their own
; files
#include “manager.d/*.conf” [/i]

now after doing this i then made sure that it was working. i did the make checkconfig and everything listed as ok. as seen below
[i]root@guiplug:/home/guiplug/Documents/asterisk-gui-2.1.0-rc1# make checkconfig
— Checking Asterisk configuration to see if it will support the GUI —

  • Checking for http.conf: OK

  • Checking for manager.conf: OK

  • Checking if HTTP is enabled: OK

  • Checking if HTTP static support is enabled: OK

  • Checking if manager is enabled: OK

  • Checking if manager over HTTP is enabled: OK
    — Everything looks good —

  • GUI should be available at guiplug:8088/asterisk/static/config/index.html

  • Note: If you have bindaddr= in /etc/asterisk/http.conf
    you will only be able to visit it from the local machine.

    Example: localhost:8088/asterisk/static/config/index.html

  • The login and password should be an entry from /etc/asterisk/manager.conf
    which has ‘config’ permission in read and write. For example:

    secret = mysecret2622
    read = system,call,log,verbose,command,agent,config
    write = system,call,log,verbose,command,agent,config

— Good luck! — [/i]
as you can see I throught i got it working haha :smile: nothing is easy in debian lol

I then did the http show status and this is what was listed, i’ve seen that on other print outs there is is more listed hwoever i don’t know what i’ve done but i think that its something not installed or not configured correctly.

g[i]uiplug*CLI> http show status
HTTP Server Status:
Prefix: /asterisk
Server Enabled and Bound to

Enabled URI’s:
/asterisk/httpstatus => Asterisk HTTP General Status
/asterisk/phoneprov/… => Asterisk HTTP Phone Provisioning Tool
/asterisk/static/… => Asterisk HTTP Static Delivery

Enabled Redirects:
/ => /static/config/cfgbasic.html[/i]

bascailly i can connect to the server however i get the error messsage

Not Implemented

Attempt to use unimplemented / unsupported method

Asterisk Server

and thisis from another computer o nthe network so i know that the server is working, but i think that it could be something to do with thwe micro http server inside, but i’m now completly lost. as people have said a huge amount of different stuff, making it hard to pin point my problem, don’t get me wrong i’ve tried them all before i came here. but you guys and girls are my last resort other than that i don\t have a clue. I would be very much in anyones debt if they could help me with this. Thank you for your time.:frowning:

Plus i’'m sorry for my grammar. if you want me to explain anything again no problem.

This is on a Dreamplug with Debian squeeze.

Kind regards

Joshua Shipman

Asterisk 1.6 is past final end of life. Most people use FreePBX, rather than Asterisk GUI.

I understand that 1.6 is past its due date.

however its the only one I’ve been able to install without multiply problems on the dream plug i have.
and the GUI said that it still supported 1.6, so i was thinking it would work.

I was just wondering if anyone would be able to offer any more advise. but because its end of life, would know one help me then ?

Kind Regards

Joshua Shipman

The significance of the end of life status is that quite a few people use old versions without checking the support status. There should still be quite a few people who know 1.6.

Asterisk GUI may be more of a problem, as most of the users will have used it as part of older versions of AsteriskNow. (I think Ian may have some knowledge.)

Thank you very much,

yes i understand, I’ve just read the part of march the 12 Debian is pretty much no longer supported.

which is rather annoying haha :smile:

but oh well. i only need for my final year project. then i wanna upgrade but i don’t have time to go through the fuss of additional problems with 1.8 i might try it tomorrow, just uninstalling asterisk and install asterisk-1.8 and hopefully it will work :smile:

Kind Regards

Joshua Shipman

Right well i’ve upgraded to 1.8.20

however i’ve run into more problems i’ve been unable to uninstall the GUI 2.0

but i can now connect on a local basis but it seems that what ever i put in the /etc/asterisk/http.conf and manager.conf doesn’t have any affect i’m thinking because I removed Asterisk 1.6 and then installed 1.8, somehow the GUI is integrated with the old 1.6 and doesn’t work on the 1.8 but i need to change the manager.conf as it won’t let me login. so i’m a little lost, does 1.8 come with its own GUI ?

Kind Regards

Joshua Shipman

The 2.0 gui was interesting. I might say that perhaps a few bug revisions could fix the issue with redundant lines and a few other things… But for complete QA you should look to the supported main branches or regular asterisk.

well i’ve now got it all working haah :smile: i’ve another problem i will share in another post which is quite annoying.