Asterisk 1.2.4 & EICON Diva Server PRI


#1

Hi all,
I have one big problem regarding instalation of EICON Diva server PRI card

I did succesfully compile drivers but when I try to load it with modprobe or web interface I get message No Diva adapters found, with dmesg I get divadid driver loaded and next message is divadid driver unloaded without saying why :frowning:

I use CenOS 4.2 final (kernel 2.6.13…), asterisk 1.2.4. …
I know that this is not asterisk problem but if someone can help me, I would be very happy :smile:

Thanks,
Marko


#2

[quote=β€œmarko”]Hi all,
I have one big problem regarding instalation of EICON Diva server PRI card

I did succesfully compile drivers but when I try to load it with modprobe or web interface I get message No Diva adapters found, with dmesg I get divadid driver loaded and next message is divadid driver unloaded without saying why :frowning:

I use CenOS 4.2 final (kernel 2.6.13…), asterisk 1.2.4. …
I know that this is not asterisk problem but if someone can help me, I would be very happy :smile:

Thanks,
Marko[/quote]

Sorry kernel version is 2.6.11


#3

OK,
I found that problem was with my IBM @server 336 series.

PCI: Device 05:01.0 not available because of resource collisions
divas: Can not enable PCI card (e01c:0005:0008)<3>divas: No cards found !

lspci -vvv
Network controller: Eicon Networks Corporation Diva Server PRI Rev 3 (rev 01)
Subsystem: Eicon Networks Corporation Diva Server PRI/E1/T1
Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR+ FastB2B-
Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- SERR- <PERR-
Interrupt: pin A routed to IRQ 0
Region 0: Memory at (32-bit, non-prefetchable) [disabled] [size=512]
Region 1: I/O ports at [disabled] [size=256]
Region 2: Memory at (32-bit, non-prefetchable) [disabled] [size=8M]
Region 3: Memory at (32-bit, non-prefetchable) [disabled] [size=256K]
Capabilities: [40] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=1 PME-
Capabilities: [48] #06 [0000]
Capabilities: [4c] Vital Product Data

It’s BIOS could not assign IRQ to EICON PCI card, and I could not set it manually (there is no such feature in BIOS) so I put EICON PCI card in another server (SUN) and set it up in few seconds :smiley:

Now everithing works fine