Asteirsk 1.8 Crashing

Asterisk 1.8 is Crashing again and again, I have full debug enabled, but not able to find the culprit. What else i can do to figure out causes of crash?


We have instructions here: … +Backtrace

to get a backtrace and then post to the issue tracker:


Asterisk is not producing core file. Asterisk is not exactly crashing(shutting down), it just freezes we cannot make any sip calls. But if i run any CLI Command for example core show channels, sip show peers it work fine. I even tried to register new sip account at that time and asterisk is accepting registration also at the time of freeze. If i make any call i see following in cli:

VERBOSE[29826] pbx.c: – Executing [6040000000@internal:1] Dial(“SIP/username-00000685”, “SIP/6040000000@SIPSERVER2”) in new stack
VERBOSE[29826] netsock.c: == Using UDPTL CoS mark 5
VERBOSE[29826] netsock2.c: == Using SIP RTP CoS mark 5

If i stop asterisk, i does not stop instantaneously. I see following messages in cli and then after 30-50 seconds asterisk shutdown.

[Dec 17 11:30:37] WARNING[18274] channel.c: Channel allocation failed: Refusing due to active shutdown
[Dec 17 11:30:37] WARNING[18274] chan_sip.c: Unable to allocate AST channel structure for SIP channel
[Dec 17 11:30:37] NOTICE[18274] chan_sip.c: Unable to create/find SIP channel for this INVITE

I have full log saved for this crash if that can help.
Note: Asterisk 1.4.36 was working fine with current situation i only faced this problem when i upgraded to 1.8.1. Asterisk 1.8.1 and 1.8.2-rc1 both doing exactly same. It only happens in day time when call volume is high, i have not seen asterisk freezing when call volume is low.

Please advice what should i do next.


See the Getting Information For A Deadlock section of that Wiki page - it’s possible that something is getting locked and not released improperly.

Thanks for reply.

For further information on this topic, please check

Great, thank you :smile: