no worked after move to https

Now work only with https, so I can’t connect to server with http. I try proxy with https, but base_url receive from asterisk with http. For example https: // will display list of resources, but every resource is unavailable, because base_url remained with http.
I try replace http with https in /var/lib/asterisk/rest-api/resources.json in base_url, but it is not halped. Anybody can connect now to your asterisk in swagger?

I’ve created an internal issue for it. The actual site you are referring to is swagger-ui, and you could probably use a tool to download all the contents and use it locally. It’s not a server, it’s just statically delivered content of HTML+CSS+Javascript.

1 Like

Сan You learn more about download tool? Or link where i can read about this… In index.html relative paths to scripts are written, not links (src=‘swagger-ui.js’, src=‘lib/swagger.js’). Where can I find this content?

They would be on the webserver, for example:

1 Like

The https redirect is now disabled.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.