Anybody got any idea how to use the applicationmap feature?


#1

Anybody got this thing figured out?

I tried to extrapolate from the minimalist documentation. Here’s what I want to do: when dialed in to my cell phone voicemail, I need to enter my 10-digit phone number (aside: I think this is a minimal security enhancement by my cell phone carrier; previously, if I spoofed my callerid from asterisk to pretend I’m my cell phone, it would immediately enter voicemail and prompt for a password [further astounding aside: a recent upgrade to voicemail made the DEFAULT for all voicemail accounts to be NO PASSWORD. Furthermore, not only did you have to create a password, you also had to go specifically enable the feature to check passwords!!!] Somewhere, recently, they appear to have changed things so that now, spoofing my cell phone callerid is no longer enough to enter voicemail; now I need to enter the 10-digit number).

Anyway, the net effect is that my little spoofing trick doesn’t work, I miss the feature, and being lazy, I figured Asterisk should be able to enter my cell phone number for me. First thing I tried was the D option on the Dial command (which is supposed to playback DTMF tones when the call is answered). After an hour of fiddling with that, I decided to try plan B. The nifty new “applicationmap” feature. Which looks cool, but is, arguably (and this is saying a LOT) the worst documented feature in asterisk.

Here’s what I tried (xxxxxxxxxx represents my 10-digit cell #)

In features.conf, I have:

[applicationmap] testfeature => *9,caller,SendDTMF(xxxxxxxxxx)

In extensions.conf, I have:

exten => 750,1,Set(DYNAMIC_FEATURES=testfeature#senddtmf) exten => 750,n,SIPDtmfMode(rfc2833) exten => 750,n,Answer() exten => 750,n,Set(CALLERID(number)=xxxxxxxxxx) exten => 750,n,Dial(SIP/xxxxxx1234@telasip-gw,60,T) exten => 750,n,Hangup

When I dial extension 750, I get connected to my wireless voicemail system and when prompted to enter my 10 digit password, press *9 and get this on my console:

-- Attempting native bridge of SIP/john-desk-6304 and SIP/telasip-gw-e796 -- Attempting native bridge of SIP/john-desk-6304 and SIP/telasip-gw-e796 -- Feature Found: testfeature exten: testfeature Dec 7 21:20:25 WARNING[10036]: res_features.c:948 feature_exec_app: Could not find application (SendDTMF(xxxxxxxxx))

FWIW, I’ve tried different dtmfmodes (inband, RFC2833), and I’ve both included and excluded the “senddtmf” application from the SET(DYNAMIC_FEATURES…) line.

Anybody got any experience with this? Or any guesses on what I’m doing wrong?

Thanks in advance.
john


#2

Anybody? :smiley: