Another 503 error


#1

Here is what I have:

Suse 9.1
Broadvoice VOIP service
Asterisk
Two X-Lite phones for testing

I have been working with Asterisk for a few days now and I have been able to setup our office with extensions that are able to call each other and use voicemail. But even after setting up the sip.conf and extensions I can not get it to dial out. When I run the SIP SHOW REGISTER command I am registered with Broadvoice. I run it in debug mode and the number is getting sent to broadvoice but I instantly get the 503 Service not available error.

I have the router forwarding to the server. Any thoughts?


#2

We would need to see what you have in sip.conf for Broadvoice and also the debug of the call (sip debug peer xxxxxx).


#3

This is what I have at the top of our sip.conf file. Of course I have changed the numbers and passwords.

register => 123456789@sip.broadvoice.com::123456789@sip.broadvoice.com

[broadvoice]
type=peer
host=proxy.dca.broadvoice.com
user=phone
secret=
fromuser=123456789
username=123456789
authname=123456789
fromdomain=sip.broadvoice.com
insecure=very
context=incoming
dtmfmode=inband
dtmf=inband
canreinvite=no
qualify=yes

sip debug peer broadvoice

(no NAT) to 147.135.0.128:5060
Destroying call '08f20c7a4c8ff2c057ca45432b7029a2@192.168.1.102’
11 headers, 0 linesr*CLI>
Reliably Transmitting:
OPTIONS sip:147.135.0.128 SIP/2.0
Via: SIP/2.0/UDP 192.168.1.102:5060;branch=z9hbgfG4ae8186
From: “asterisk” sip:asterisk@192.168.1.102;tag=asdfgr4568
To: sip:147.135.0.128
Contact: sip:asterisk@192.168.1.102
Call-ID: 7b3f39ff6d194d21b5f97c902e354649@192.168.1.102
CSeq: 102 OPTIONS
User-Agent: Asterisk PBX
Date: Tue, 12 Apr 2005 09:37:13 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER
Content-Length: 0

(no NAT) to 147.135.0.128:5060
Destroying call ‘7b3f39ff6d194d21b5f97c902e354649@192.168.1.102’


#4

There are a couple of problems I see. Your register should look like:

register=phonenumber:password@sip.broadvoice.com

Your Asterisk server is behind NAT. Take a look at this page for more info regarding Asterisk and NAT:
voip-info.org/wiki-Asterisk+ … +solutions[/quote]


#5

register=phonenumber:password@sip.broadvoice.com

When I tried this it would not register. When I changed it back to:

register => 123456789@sip.broadvoice.com::123456789@sip.broadvoice.com

I show registered. I am working on the NAT info now.

Thank you for helping zmanea. It is nice to have people that take their time to help others.


#6

I have now tried to use the external IP to log into the server. The X-lite phone displays a cone NAT firewall. Shouldn’t I be able to login under the LAN IP and use the broadvoice VoIP?


#7

I have cleaned up the default sip.conf and extinsion.conf files and made some other minor changes. Now when I place a call it starts trying and kicks back a 403 Forbidden error.

  • reports

Received packet with bad checksum
Timeout, but no rule ‘t’ in context ‘default’

???


#8

Got it working now! I changed to another proxy and it starting placing outside calls.