AMI: VoicemailRefresh is not working

Hi Group

I have a separate process which moves files between the INBOX and Old folders for voicemail and I am trying to sync the MWI status for extensions.
I have tried to use the AMI: VoicemailRefresh which does nothing and also setting pollmailboxes=yes and pollfreq=10 and still it does not change the MWI status on the phone for ages.
Does anyone know what the problem could be?

Im running Asterisk 13.24.1.


PS the only thing that seems to work is a module reload but I really dont want to be doing that every time someone uses my voicemail app.

This was a bug in old versions. The newest release does not suffer from this problem.

Thanks Josh. I assume you are talking about bug 28340.
The problem is not present in Asterisk 13.23.1 but still AMI: VoicemailRefresh does not work.
Interestingly ‘voicemail reload’ refreshes MWI in 13.23.1 but not 13.24.1


Sorry all. pollmailboxes=yes does work so there must have been something else I was doing that broke this.
I will use mailbox polling instead for now.

Thanks for your help.


The latest version of Asterisk is 13.26.0. That version does not have any known MWI issues, earlier versions did.

Thanks Josh

PS I was wrong about mailbox polling in 13.24.1. It is actually broken. It worked fine for a while but then became sporadic in the poll times so you are correct.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.