Allowing inbound calls

Hi I have been tring to get inbound calls working but no matter what I do I cant seem to get it right.

I have now been told I need to allow the following IP ranges into my firewall and asterisk

but I don’t quite understand how to do this.
I have therefor dropped the firewall - which is risky at the best of times.

In my estensions.conf I have the following

;LifeAndInsurance INBOUND exten => _0390018751,1,Answer exten => _0390018751,n,AGI(agi-VDAD_ALL_inbound.agi,CIDLOOKUP-----LB-----landiinbound-----0390018751-----Closer-----park----------90030-----X) exten => _0390018751,n,Hangup

The part I am not understanding though is this part -----Closer-----park----------90030-----X. I am not sure what 90030, What I know I did was in vicidial I created an inbound group called landiinbound and setted that up correctly

You should ask with tour third party software vendor. Asterisk never use AGI to make o receive calls so definitely this is a third party vendor issue.

I can see calls are coming in to our asterisk but they are not able to find an extension

the code I am using is the following

;LifeAndInsurance INBOUND exten => 61390018751,1,Answer exten => 61390018751,n,AGI(agi-VDAD_ALL_inbound.agi,CIDLOOKUP-----LB-----landiinbound-----61390018751-----Closer-----park----------999-----X) exten => 61390018751,n,Hangup

I have even tried to

;LifeAndInsurance INBOUND

exten => 61390018751,1,Answer exten => 61390018751,n,Echo

But with no success

We can’t tell you how to open your firewall, but the very wide range of addresses means you will need to use allowguest with Asterisk, which is normally bad practice. (I’m assuming that the ITSP is not prepared to register with you and use a single address during the registration period.)

As already noted, the AGI script is not part of Asterisk.

Hi David I understand that - the issue as I see it is that asterisk cant find 61390018751.

however when i reload asterisk i see

-- Added extension '61390018751' priority 1 to defaultlog -- Added extension '61390018751' priority 2 to defaultlog

Your default context is not defaultlog.

could you explain a little more detailed please

I tried to run show dialplan but the 61390018751 was not in there. I am not sure what I have done wrong, please sample would be great or even documentation link.

Go ahead and read the bible:

I have looked further and found the following

using the debug tool

[code][Jun 25 18:16:54] NOTICE[29574]: chan_sip.c:15566 handle_request_invite: Call from ‘iVox’ to extension ‘61390018751’ rejected because extension not found.
Scheduling destruction of SIP dialog ‘c8f-537-94197082715-IMG01-0-’ in 6400 ms (Method: INVITE)

<— SIP read from —>
ACK sip:61390018751@;user=phone SIP/2.0
Via: SIP/2.0/UDP;branch=z9hG4bK1ca53b72111483dcbINV76529f9110d0
To: sip:61390018751@180.xxxx.69;user=phone;tag=as6f882f59
From: "0390141414"sip:0390141414@;user=phone;noa=national;tag=76529f91-co4304-INS001
Call-ID: c8f-537-94197082715-IMG01-0-
CSeq: 430401 ACK
Content-Length: 0[/code]

So in my sip.conf I opened
and added the following




register => 61390018751@18xxxx.69


caninvite=no ; Appears to be required for outgoing audio
canreinvite=no ; Appears to be required for outgoing audio

I can connect via the office and use an ext number but 61390018751@ still saying it is not a valid extention

While in my extension.conf I have
exten => 61390018751,1,Dial(SIP/2288|60|)
exten => 61390018751,2,Echo


Firstly NEVER post traces with real ip addresses… Too late now.

as to where the call is going do a sip show settings and see what the default context is for incomng sip calls

then add your extension in there and try again.