Allowguest in sip.conf not working as expected


I am trying to setup my * so that it accepts calls from all sip-accounts/guests. I have


in sip.conf. But when someone from another SIP Registrar calls my * all I get is an authentication error:

Oct 19 09:01:36 NOTICE[28909]: chan_sip.c:7382 handle_request: Failed to authenticate user;tag=252B9FF3D890CC93973D747DB6BB

Since I have no defined in * this sort of makes sense. There has to be a way though to allow incoming SIP calls from everybody, is there not? What am I missing?

Thanks in advance,

The way I allow guests is buy having them dial a SIP URI:

Which is then picked up in the ‘default’ context of /etc/asterisk/extensions.conf and handled appropriately. How are you having these folks dial your Asterisk instance?


in sip.conf general I point to context from_sip and in extensions.conf I have extension 43 defined. I have the impression that it never reaches that context though since the auth failed happens right along.

Try dropping the that extension in the default section of the extensions.conf as opposed to the one pointed to by sip.conf and work your way back from there.

Sorry. I don’t understand what you mean.

Let me yet again ask one more thing: Why does * say authentication failed if allowguest=yes is set in sip.conf (it is on by default anyway is it not?)? If it is some sort of extension problem it should at least accept the connection and then throw an invalid extension error or something else.

Or is authentication failed just another * way of telling me that the extension is not setup correctly? Since my IAX guest user is directed to the same context and works like a charm, I strongly doubt that the extension setup is incorrect.

The problem seems to occur only if a SIP client that is registered at another registrar is trying to connect to my *. In my example, my FritzBox!Fon is registered to my t-online account and tries to connect to the * SIP guest account.

Is there a setting for ‘allowguest’ in /etc/asterisk/sip.conf? I do not see one on the Wiki nor am I familiar with that in sip.conf:

The way I handle incoming SIP requests is:

  • /etc/asterisk/extensions.conf


exten => guest,1,Goto(wherever)

Then, if someone dials, it goes where I need it to and I may accept and process the call.

You can tell * in sip.conf whether or not it should accept non-authenticated SIP calls (allowguest). Default = yes.

If someone tries to call without any auth-try everything works fine. Some SIP-clients (like FritzBoxFon) try to authenticate with their account though (when using ENUM) which then fails since * does not accept this auth.


Do you have a pointer as to where this is present on the Wiki or in some form of documentation? I can not find it and would be interested in finding out more detail.

I learned something new today, indeed after looking at the example configs in /usr/src/asterisk-1.2beta/configs/sip.conf.sample I came across this:

Not familiar with this in detail though, would need to play around a bit. Also updated the Wiki to include a description: … g+sip.conf

I have the same problem, I can’t receive calls because of "Sep 23 18:00:48 NOTICE[28023]: chan_sip.c:10918 handle_request_subscribe: Failed to authenticate user “Blabla";tag=451e4d28 for SUBSCRIBE”

Why does the “allowguest=yes” in sip.conf ([general] context) option does not work?
btw i’ve tried all other options to get incoming calls but they do not work too :frowning: :