All call going into voicemail....help


#1

when dialing another extenion i get the busy greeting evertime,nothing rings and phones are not in DND. Running Asterisk@Home 1.5.


#2

Really, there are a large number of reasons why this could be happening.
Would i be right to assume that if you disable voicemail to one of the problem extensions, that upon calling it, you get a busy signal?

If you do, the likely reason is that your set hasn’t registered with Asterisk properly.

I’ve run into this problem a bunch of times…and every single time that I can recall, it was due to me missing a configuration.

From the command line, type asterisk -cvvvr and startup one of your softphones or restart one of your hardsets. You should see something in the log like the following:

Registered SIP ‘2145’ at 192.168.1.100 port 5061 expires 1800
(translation:Registered SIP ‘Extension number 2145’ at IP address 192.168.17.192 port 5061 expires 1800)

If you do see that the softphone is registering properly, then press enter a couple of times in the asterisk live log (so that you know where your call will begin in the log, it adds a few blank lines) attempt to recreate the problem, (1 call only please) then copy paste the log into the forum so that we can look. Usually the log will tell experienced users what is going on.


#3

here is the log from this server and below this one is a test server I built a couple weeks ago that works fine,

/var/log/asterisk/full - last 2000 lines

Nov 8 14:14:53 VERBOSE[1987]: – Added extension ‘s-BUSY’ priority 2 to macro-dialout-trunk
Nov 8 14:14:53 VERBOSE[1987]: – Added extension ‘s-BUSY’ priority 3 to macro-dialout-trunk
Nov 8 14:14:53 VERBOSE[1987]: – Added extension ‘s-BUSY’ priority 4 to macro-dialout-trunk
Nov 8 14:14:53 VERBOSE[1987]: – Added extension ‘_s-.’ priority 1 to macro-dialout-trunk
Nov 8 14:14:53 VERBOSE[1987]: – Registered extension context 'macro-agent-add’
Nov 8 14:14:53 VERBOSE[1987]: – Added extension ‘s’ priority 1 to macro-agent-add
Nov 8 14:14:53 VERBOSE[1987]: – Added extension ‘s’ priority 2 to macro-agent-add
Nov 8 14:14:53 VERBOSE[1987]: – Added extension ‘s’ priority 3 to macro-agent-add
Nov 8 14:14:53 VERBOSE[1987]: – Added extension ‘s’ priority 4 to macro-agent-add
Nov 8 14:14:53 VERBOSE[1987]: – Added extension ‘s’ priority 5 to macro-agent-add
Nov 8 14:14:53 VERBOSE[1987]: – Added extension ‘s’ priority 6 to macro-agent-add
Nov 8 14:14:53 VERBOSE[1987]: – Added extension ‘s’ priority 7 to macro-agent-add
Nov 8 14:14:53 VERBOSE[1987]: – Added extension ‘s’ priority 8 to macro-agent-add
Nov 8 14:14:53 VERBOSE[1987]: – Added extension ‘s’ priority 9 to macro-agent-add

In house test server log, this one works fine:

Nov 8 13:59:09 DEBUG[1098]: Stopping retransmission on ‘1c069e2e11adab5e36726b5150887143@127.0.0.1’ of Request 103: Found
Nov 8 13:59:09 DEBUG[1098]: Registration successful
Nov 8 13:59:09 DEBUG[1098]: Cancelling timeout 49404
Nov 8 13:59:09 VERBOSE[2960]: == Parsing ‘/etc/asterisk/extensions_additional.conf’: Nov 8 13:59:09 VERBOSE[2960]: == Parsing ‘/etc/asterisk/extensions_additional.conf’: Found
Nov 8 13:59:09 VERBOSE[2960]: == Parsing ‘/etc/asterisk/extensions_custom.conf’: Nov 8 13:59:09 VERBOSE[2960]: == Parsing ‘/etc/asterisk/extensions_custom.conf’: Found
Nov 8 13:59:09 VERBOSE[2960]: – Setting global variable ‘VM_PREFIX’ to '*'
Nov 8 13:59:09 VERBOSE[2960]: – Setting global variable ‘RINGTIMER’ to '15’
Nov 8 13:59:09 VERBOSE[2960]: – Setting global variable ‘REGTIME’ to '7:55-17:05’
Nov 8 13:59:09 VERBOSE[2960]: – Setting global variable ‘REGDAYS’ to 'mon-fri’
Nov 8 13:59:09 VERBOSE[2960]: – Setting global variable ‘RECORDEXTEN’ to '""'
Nov 8 13:59:09 VERBOSE[2960]: – Setting global variable ‘PARKNOTIFY’ to 'SIP/200’
Nov 8 13:59:09 VERBOSE[2960]: – Setting global variable ‘OUT_3’ to 'SIP/junction’
Nov 8 13:59:09 VERBOSE[2960]: – Setting global variable ‘OUT_2’ to 'IAX2/junction’
Nov 8 13:59:09 VERBOSE[2960]: – Setting global variable ‘OUT_1’ to 'ZAP/g0’
Nov 8 13:59:09 VERBOSE[2960]: – Setting global variable ‘OUTPREFIX_3’ to ''
Nov 8 13:59:09 VERBOSE[2960]: – Setting global variable ‘OUTPREFIX_2’ to ''
Nov 8 13:59:09 VERBOSE[2960]: – Setting global variable ‘OUTMAXCHANS_3’ to ''
Nov 8 13:59:09 VERBOSE[2960]: – Setting global variable ‘OUTMAXCHANS_2’ to ‘’


#4

here is a better log file:

Nov 8 15:15:37 DEBUG[1987]: Expression is '0’
Nov 8 15:15:37 VERBOSE[1987]: – Executing GotoIf(“SIP/202-43d9”, “0?4:3”) in new stack
Nov 8 15:15:37 VERBOSE[1987]: – Goto (macro-dial,s,3)
Nov 8 15:15:37 VERBOSE[1987]: – Executing SetCIDName(“SIP/202-43d9”, “”) in new stack
Nov 8 15:15:37 VERBOSE[1987]: – Executing AGI(“SIP/202-43d9”, “dialparties.agi”) in new stack
Nov 8 15:15:37 VERBOSE[1987]: – Launched AGI Script /var/lib/asterisk/agi-bin/dialparties.agi
Nov 8 15:15:37 VERBOSE[1987]: – AGI Script dialparties.agi completed, returning 0
Nov 8 15:15:37 VERBOSE[1987]: – Executing NoOp(“SIP/202-43d9”, “Returned from dialparties with no extensions to call”) in new stack
Nov 8 15:15:37 VERBOSE[1987]: – Executing SetVar(“SIP/202-43d9”, “DIALSTATUS=BUSY”) in new stack
Nov 8 15:15:37 DEBUG[1987]: Expression is '0’
Nov 8 15:15:37 VERBOSE[1987]: – Executing GotoIf(“SIP/202-43d9”, “0?s-BUSY|1”) in new stack
Nov 8 15:15:37 DEBUG[1987]: Not taking any branch
Nov 8 15:15:37 DEBUG[1987]: Expression is '0’
Nov 8 15:15:37 VERBOSE[1987]: – Executing GotoIf(“SIP/202-43d9”, “0?s-BUSY|1”) in new stack
Nov 8 15:15:37 DEBUG[1987]: Not taking any branch
Nov 8 15:15:37 VERBOSE[1987]: – Executing NoOp(“SIP/202-43d9”, “Sending to Voicemail box 201@default”) in new stack
Nov 8 15:15:37 VERBOSE[1987]: – Executing Macro(“SIP/202-43d9”, “vm|201@default|BUSY”) in new stack
Nov 8 15:15:37 VERBOSE[1987]: – Executing Goto(“SIP/202-43d9”, “s-BUSY|1”) in new stack
Nov 8 15:15:37 VERBOSE[1987]: – Goto (macro-vm,s-BUSY,1)
Nov 8 15:15:37 VERBOSE[1987]: – Executing VoiceMail(“SIP/202-43d9”, “b201@default”) in new