Agent Login and queues?

I have setup Asterisk 18.21. I have incoming setup ready. I have configured the queues.
When there is an incoming call, the available queue members should get the calls. In old asterisk, the agentCallbackLogin application allows us to login the agents in queue. but in latest asterisk how to do this ?

I have setup the agents.conf

But when I check the agents on CLI :

renav-vps*CLI> agent show 7001
Agent ‘7001’ not found

How to add the agents, how to login them in queue ?

I tried but didnt get much luck. Any help how to do agentLogin in asterisk ?

You’d have to actually state what you’ve done, the configuration, and what happened.

On Monday 15 April 2024 at 19:16:24, urmi.l via Asterisk Community wrote:

I tried but didnt get much luck. Any help how to do agentLogin in asterisk

Your question is (I think) unclear. Please explain precisely what you are
trying to do, and also tell us what you have tried so far and “didn’t get much
luck” with.


What do you get when you cross a joke with a rhetorical question?

                                               Please reply to the list;
                                                     please *don't* CC me.

I did below configurations :

load =>
load =>


Asterisk CLI :

vpsCLI> module load
Unable to load module
Command ‘module load’ failed.
== Manager registered action Agents
== Manager registered action AgentLogoff
== Registered custom function ‘AGENT’
== Registered application ‘AgentLogin’
== Registered application ‘AgentRequest’
== Unregistered application ‘AgentLogin’
== Unregistered application ‘AgentRequest’
== Unregistered custom function AGENT
== Manager unregistered action Agents
== Manager unregistered action AgentLogoff

How to use the agentcallbacklogin to login the agents and use it with queues ?

“agent” and “password” are not valid configuration options.

What is correct configurations ?

The blog post I linked has configuration, as well as dialplan logic.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.