AEL Features in 1.2 RC2


#1

So, I’m experiementing with Asterisk 1.2 RC2.

Seems that you STILL have to completely stop and restart asterisk for changes made to extensions.ael to become applied.

It also seems that #include doesn’t work.

Call me crazy, but I would have thought that these where two features that would have been show stoppers for the final 1.2 release. They certainly are show stoppers for us, as I imagine they would be for anyone in a production environment.


#2

I agree, these are two key features that should really be a part of any RC/General Release. As AEL is largely unuseable in a serious environment without reload capabilities. Also, it appears what is recommended on the Wiki, does not work either:

voip-info.org/wiki/view/Asterisk+AEL

Although I have not tested on RC2, or had a chance to see if it is considered a bug or is not included as a feature.


#3

Yip. I tried both reload and reload pbx_ael.so. Funny… ‘stop now’ worked. :stuck_out_tongue:


#4

Someone on the VOIP wiki wrote:

Reloading pbx_ael.so doesn’t reload extensions
Bizarely, the following does it
unload pbx_ael.so
load pbx_ael.so


#5

Interesting workaround.

These two issues (I don’t know how they are NOT bugs, but…) are the main reason I stopped playing with AEL a couple weeks ago.

The irony is that with a new feature like this, you probably want to gradually migrate your extensions.conf to extensions.ael (and #include friends), so both features seem pretty essential.