Ztdummy


#1

Hi All,

I have couple of questions which most likely will help solve my problem with iax sound and help many more like me. I use g729a and have proper license for it however, i am not using digium’s hardware. I am simply going VoIP over ethernet but my voice quality with iax trunking is pretty bad (inconsistent and choppy) with g729a for one user with 512/512 connection.
I just upgraded my asterisk to the latest 1.2.7 as well. My frame buffer in my lilo.conf is also off as someone mentioned that it could make the sound choppy.

Question1: I can see the zapata.conf in /etc/asterisk and zaptel.conf in /etc. In my case are these files needed?

Question2: In my extensions.conf I can see the section for TRUNK and CHANNEL where its ZAP/g2 etc are defined. What should it have there? Since mine i believe is only a pseudo channel, I am not sure if the default in the extensions.config is correct.

Question3: I saw in some forums that there is a rtc driver for 2.6 kernel. Would anyone have any comment on whether i should use it?

thanks in advance.


#2

What kernel are you running?

You don’t need to do anything with these, since you don’t actually have any zaptel hardware.

I think the “TRUNK” and “CHANNEL” are just some preset variables in your dialplan :smile:

ztdummy uses uhci-usb with 2.4 kernels for timing and the rtc with 2.6 kernels.

Cheers
Stoyan


#3

I am using kernel 2.6
It is really weird. I tried modifying some fields in zapata.conf and it did make some difference in my phone calls.
I am not sure what else i can do to solve this g729 sound issue. I’ll do some more tests and will post back some info to see if it can be solved.
thanks


#4

Hmm, not possitive, but I don’t think you need ztdummy with 2.6 kernel.


#5

If yoo don’t have any digium hardware then you have to use ztdummy if you are doing iax trunking or meetme conferencing.

Make sure that you have installed the zaptel drivers first and follow the instructions for compiling them. If you are running 2.6 kernel then make sure you do make linux26 whcih will compile in the ztdummy driver from the latest sources.

Everything shoudl work fine after that. If you didnt install the zaptel drivers before compiling asterisk, you will need to install zaptel, then make and make install on asterisk so that it will see teh zaptel headers and compile the asterisk modules correctly.

I missed that on one server and took 2 days to figure it out.


#6

[quote=“gk1”]If yoo don’t have any digium hardware then you have to use ztdummy if you are doing iax trunking or meetme conferencing.
[/quote]

what is the difference between iax trunking and simple iax registration like say using the iax gateway with FWD. I did see a message in the log saying it cannot find the zap device but I can register to FWD(through iax) and have two way communication just fine, thus a bit puzzled about this iax requirement.


#7

thanks for all of your replies:

I do have a properly compiled kernel 2.6 and properly installed zaptel and ztdummy. Here is my dmesg: Not sure if this points to anything but I am using IAX trunking. Although i don’t do any meetme and one user with so much of bandwidth it should have worked well but it is just puzzling. Its been around 4 months. I had been in touch with Digium as well but they wanted root access to diagnose problem which i couldn’t offer. I am not sure if any rx/tx gains etc will make any diff. Any information or suggestions please do post. The only thing that is not active is any alsa modules (sound card modules) within my linux. If that needs to be on, I’ll certainly do that.

thanks

lsmod:

root@sp:~# lsmod
Module Size Used by
ztdummy 2800 -
zaptel 222724 -
crc_ccitt 1704 -


dmesg:

Losing too many ticks!
TSC cannot be used as a timesource.
Possible reasons for this are:
You’re running with Speedstep,
You don’t have DMA enabled for your hard disk (see hdparm),
Incorrect TSC synchronization on an SMP system (see dmesg).
Falling back to a sane timesource now.
Zapata Telephony Interface Registered on major 196
Zaptel Version: 1.2.5 Echo Canceller: KB1
Registered tone zone 1 (Australia)
rtc: lost some interrupts at 1024Hz.


Zttest result:

root@sp:/tmp/asterisk_new/zaptel-1.2.5# ./zttest
Opened pseudo zap interface, measuring accuracy…
99.951172% 99.951172% 99.951172% 99.951172% 99.841309% 99.951172% 99.951172%
99.951172% 99.951172% 99.951172% 99.951172% 99.951172% 99.951172% 99.951172%
— Results after 14 passes —
Best: 99.951172 – Worst: 99.841309 – Average: 99.943324