Zaptel problem

I bought TDM844P
But when I finish the driver install .
I get

[color=red] [root@asterisk ~]# dmesg | grep FXO
Port 1: Installed – AUTO FXO (FCC mode)
Port 2: Installed – AUTO FXO (FCC mode)
Port 3: Installed – AUTO FXO (FCC mode)
Port 4: Installed – AUTO FXO (FCC mode)
Port 1: Installed – AUTO FXO (FCC mode)
Port 2: Installed – AUTO FXO (FCC mode)
Port 3: Installed – AUTO FXO (FCC mode)
Port 4: Installed – AUTO FXO (FCC mode)[/color]

[color=cyan][root@asterisk ~]# dmesg | grep FXS
Port 5: FAILED FXS (FCC)
Port 6: FAILED FXS (FCC)
Port 7: FAILED FXS (FCC)
Port 8: FAILED FXS (FCC)
Port 5: FAILED FXS (FCC)
Port 6: FAILED FXS (FCC)
Port 7: FAILED FXS (FCC)
Port 8: FAILED FXS (FCC)[/color]

I think it should be 4 FXO 4 FXS. Is that right?
And I didn’t plug the power cable, because the cable is too short to plug in.
Could someone tell me what is the correct output?

What happen is this?

[color=red][root@asterisk ~]# /etc/rc.d/init.d/zaptel restart
Unloading zaptel hardware drivers:.
Loading zaptel framework: [ OK ]
Waiting for zap to come online…OK
Loading zaptel hardware modules: wctdm24xxp.
Running ztcfg: ZT_CHANCONFIG failed on channel 1: Invalid argument (22)
Did you forget that FXS interfaces are configured with FXO signalling
and that FXO interfaces use FXS signalling?
[FAILED][/color]

First of all please dont start new threads with the same issue - it just makes it harder to follow.

Second, you need to plug the card into your pc power for the fxs ports to work.

Third your zaptel.conf should look something like:

loadzone=us defaultzone=us fxks=1-4 fxoks=5-8

and your zapata.conf file should something look like:

[code]signalling=fxs_ks
language=en
context=incoming
channel=1-4

signalling=fxo_ks
language=en
context=incoming
channel=5-8[/code]

Note: you may need to adjust the language, loadzone, defualtzone and context to suit your location\configuration.

Also, as another option because you bought a Digium card you can contact them for installation support - thats the great part about buying Digium cards, they work and they come with support!

[quote=“swaterhouse”]First of all please dont start new threads with the same issue - it just makes it harder to follow.

Second, you need to plug the card into your pc power for the fxs ports to work.

Third your zaptel.conf should look something like:

loadzone=us defaultzone=us fxks=1-4 fxoks=5-8

and your zapata.conf file should something look like:

[code]signalling=fxs_ks
language=en
context=incoming
channel=1-4

signalling=fxo_ks
language=en
context=incoming
channel=5-8[/code]

Note: you may need to adjust the language, loadzone, defualtzone and context to suit your location\configuration.

Also, as another option because you bought a Digium card you can contact them for installation support - thats the great part about buying Digium cards, they work and they come with support![/quote]

If I live in Taiwan how can I setup the loadzone and defaultzone?
Can I set it to “tw” or anything else?
Why should I setup the language and where can I set it?
Thanks for help!

Most of this is in the wiki

http://www.voip-info.org/wiki-Asterisk+config+zaptel.conf

and

http://www.voip-info.org/wiki-Asterisk+config+zapata.conf

I guess you could try this in zaptel.conf

loadzone=tw defaultzone=tw fxks=1-4 fxoks=5-8

and in zapata.conf you would change the line(s)

language=en

to language=tw (or whatever you want as your prompt languange)

see here for an explanation

http://www.voip-info.org/wiki/index.php?page=Asterisk+multi-language

[quote=“swaterhouse”]Most of this is in the wiki

http://www.voip-info.org/wiki-Asterisk+config+zaptel.conf

and

http://www.voip-info.org/wiki-Asterisk+config+zapata.conf

I guess you could try this in zaptel.conf

loadzone=tw defaultzone=tw fxks=1-4 fxoks=5-8

and in zapata.conf you would change the line(s)

language=en

to language=tw (or whatever you want as your prompt languange)

see here for an explanation

http://www.voip-info.org/wiki/index.php?page=Asterisk+multi-languag
e
[/quote]

I do all the setting and plug the power

[color=green][root@asterisk ~]# dmesg| grep FXO
Port 1: Installed – AUTO FXO (FCC mode)
Port 2: Installed – AUTO FXO (FCC mode)
Port 3: Installed – AUTO FXO (FCC mode)
Port 4: Installed – AUTO FXO (FCC mode)
Port 1: Installed – AUTO FXO (FCC mode)
Port 2: Installed – AUTO FXO (FCC mode)
Port 3: Installed – AUTO FXO (FCC mode)
Port 4: Installed – AUTO FXO (FCC mode)

[root@asterisk ~]# dmesg| grep FXS
Port 5: Installed – AUTO FXS/DPO
Port 6: Installed – AUTO FXS/DPO
Port 7: Installed – AUTO FXS/DPO
Port 8: Installed – AUTO FXS/DPO
Port 5: Installed – AUTO FXS/DPO
Port 6: Installed – AUTO FXS/DPO
Port 7: Installed – AUTO FXS/DPO
Port 8: Installed – AUTO FXS/DPO
[/color]

But it still have problem
[color=red]
[root@asterisk ~]# /etc/rc.d/init.d/zaptel restart
Unloading zaptel hardware drivers:.
Loading zaptel framework: [ OK ]
Waiting for zap to come online…OK
Loading zaptel hardware modules: wctdm24xxp.
Running ztcfg: ZT_CHANCONFIG failed on channel 1: Invalid argument (22)
Did you forget that FXS interfaces are configured with FXO signalling
and that FXO interfaces use FXS signalling?
[FAILED]
[/color]

[quote=“bryant”][quote=“swaterhouse”]Most of this is in the wiki

http://www.voip-info.org/wiki-Asterisk+config+zaptel.conf

and

http://www.voip-info.org/wiki-Asterisk+config+zapata.conf

I guess you could try this in zaptel.conf

loadzone=tw defaultzone=tw fxks=1-4 fxoks=5-8

and in zapata.conf you would change the line(s)

language=en

to language=tw (or whatever you want as your prompt languange)

see here for an explanation

http://www.voip-info.org/wiki/index.php?page=Asterisk+multi-languag
e
[/quote]

I do all the setting and plug the power

[color=green][root@asterisk ~]# dmesg| grep FXO
Port 1: Installed – AUTO FXO (FCC mode)
Port 2: Installed – AUTO FXO (FCC mode)
Port 3: Installed – AUTO FXO (FCC mode)
Port 4: Installed – AUTO FXO (FCC mode)
Port 1: Installed – AUTO FXO (FCC mode)
Port 2: Installed – AUTO FXO (FCC mode)
Port 3: Installed – AUTO FXO (FCC mode)
Port 4: Installed – AUTO FXO (FCC mode)

[root@asterisk ~]# dmesg| grep FXS
Port 5: Installed – AUTO FXS/DPO
Port 6: Installed – AUTO FXS/DPO
Port 7: Installed – AUTO FXS/DPO
Port 8: Installed – AUTO FXS/DPO
Port 5: Installed – AUTO FXS/DPO
Port 6: Installed – AUTO FXS/DPO
Port 7: Installed – AUTO FXS/DPO
Port 8: Installed – AUTO FXS/DPO
[/color]

But it still have problem
[color=red]
[root@asterisk ~]# /etc/rc.d/init.d/zaptel restart
Unloading zaptel hardware drivers:.
Loading zaptel framework: [ OK ]
Waiting for zap to come online…OK
Loading zaptel hardware modules: wctdm24xxp.
Running ztcfg: ZT_CHANCONFIG failed on channel 1: Invalid argument (22)
Did you forget that FXS interfaces are configured with FXO signalling
and that FXO interfaces use FXS signalling?
[FAILED]
[/color][/quote]

I change

[color=red]fxks=5-8
fxoks=1-4[/color]

It can work no error message!
Could you tell me why I need to set it opposite?
Thanks!

The answer was right in the error message:

Did you forget that FXS interfaces are configured with FXO signalling
and that FXO interfaces use FXS signalling?

The files I gave you were edited from my test files and I didn’t pay attention to your output - sorry about that.

Glad you got it working.

But it still confuse me.
Why the dmesg command shows FXO is port 1 to 4
and FXS is port 5 to 8.
But in zaptel.conf we set it to fxoks=5-8
fxsks=1-4

Now how can I plug the phone line in the port???
Plug the phone side in 1-4 port or line side in 1-4 port?