Zaptel problem: Invalid module format

Zaptel 1.2.15, Asterisk 1.2.16 on Slackware 11.0 box and kernel

Zaptel compiled and installed without errors.

To get Asterisk to compile, I had to add:
#include <linux/compiler.h>
above this line:
#include <linux/ixjuser.h>
in chan_phone.c. I have no idea why or what that does… I just found that solution to my error by searching online and it does the trick… Asterisk compiled and installed after that.

However when I try to load the zaptel module I get the following.

FATAL: Error inserting zaptel (/lib/modules/ Invalid module format

I see by searching that this can be caused by having a version of gcc installed which is different from what was used to compile the kernel, but this does not seem to be the case here:

gcc -v

Reading specs from /usr/lib/gcc/i486-slackware-linux/3.4.6/specs
Configured with: …/gcc-3.4.6/configure --prefix=/usr --enable-shared --enable-threads=posix --enable-__cxa_atexit --disable-checking --with-gnu-ld --verbose --target=i486-slackware-linux --host=i486-slackware-linux
Thread model: posix
gcc version 3.4.6

cat /proc/version

Linux version (root@tree) (gcc version 3.4.6) #1 Sat Sep 9 01:11:49 CDT 2006

Can anyone help me out here?


Do you have CONFIG_CRC_CCITT=y or CONFIG_CRC_CCITT=m in your kernel?

In the Zaptel 1.2.15 README it has the following, although not the exact, but similar error:

[code]Q. Zaptel compiled with no errors but when I try to modprobe zaptel I
receive "FATAL: Error insering zaptel (/lib/modules/2.6.x.x/misc/zaptel.ko):
Unknown symol in module or unknown parameter (see dmesg)

A. You need to recompile your kernel with CONFIG_CRC_CCITT=y or
CONFIG_CRC_CCITT=m. To do this, run ‘make menuconfig’ and change it under
’Library Routines -> CRC-CCIT functions’. If you compiled it as a module,
load it, otherwise reboot.

Hi - thanks for the reply. Yes it is there as a module in my kernel, and a:

modprobe crc_ccitt

returns no errors. Howver, even after that I get:

modprobe zaptel

FATAL: Error inserting zaptel (/lib/modules/ Invalid module format

Does anyone else have an idea?

Did you build zaptel for a 2.6 kernel? (making sure the linux symlink points to the correct kernel)

i.e. make linux26
make install

“make linux26” in zaptel 1.2.15 results in a “no target found” error.

in addition to the previous posts, i would suggest checking for multiple installations of zaptel modules. i’ve seen them “move” with kernel changes, and you may well be attempting to load modules compiled for a previous kernel. strip out the old stuff, start fresh.


have you resolve this issue?

No, I’ve checked for other versions of the module and anything else I could think of but still get that same error :frowning: I’m gonna try a fresh install of Slackware I think unless someone else can help me?

what’s your kernel version ?

opps … just saw that in the OP … ignore me :smiley: