Zaptel installation issues


I am trying to install zaptel1.4 in a machine, where i do not have internet access to it.

when compiling (make install) i get the following error

make -C firmware hotplug-install DESTDIR= HOTPLUG_FIRMWARE=yes
make[1]: Entering directory /usr/src/zaptel-1.4/firmware' Attempting to download zaptel-fw-oct6114-064-1.05.01.tar.gz --18:55:07-- [ ... .01.tar.gz]( =>zaptel-fw-oct6114-064-1.05.01.tar.gz’
Resolving… failed: Temporary failure in name resolution.
make[1]: *** [zaptel-fw-oct6114-064-1.05.01.tar.gz] Error 1
make[1]: Leaving directory `/usr/src/zaptel-1.4/firmware’
make: *** [install-firmware] Error 2

I understand, it is trying to download a file from internet, my concern is internet connectivity to the machine. Internet access to this machine is denied by default by my IT team.

how could i fix this installation issues, but i can download the same file from some other system and i can copy it.

How could do i fix this issues?

Thanks in advance

Any help ???


guys have ever faced this kind of problem?

Well me I have never tried to install a asterisk box with out Inet access

You could go thru the install file and grab the files
try to dump them zaptel src folder

But really the best thing is to put the box on the inet to install and patch up the box


A few options realy, Speak to the IT dept and get them to allow access to Digium at least or more sensibly allow access for all addresses from that machine.

another option is to go through the make file and edit it to reflect having the files locally and then download all files mentioned that will require downloading.

Or what I do is carry a 3g Data dongle in my briefcase and use that.


i just fixed it , by downloading the required files from another machine, where i saw the errors, extracted it and dumped the bin file in the appropriate folders… it worked…