Zaptel echos

I’m just starting out with Asterisk and I have two Digim Zaptel cards, which have 8 PSTN lines connected. I’m getting a lot of echo on oneside of the conversation.

I’ve been doing some reading and I’ve been using the ‘ztmonitor’ program to adjust my gains and this seems to be helping. The problem is if I lower the txgain below -6 then I cannot call out on that channel. What happens is it looks like it’s making a call but never does, it’s just silent and the destination phone doesn’t ring. Here is the output

It would be nice if I could test txgain on -11 and rxgain on 0.[/code]

Sometimes the echo is not in your control
Who are the lines from???

I ALWAYS have echo on lines from CLEC’s
Never on true Bell copper

i think you’re doing it backward. you need to reduce rxgain, since the zaptel defines rx as it receiving data from you (your handset mic) and txgain is sending data to your handset speaker. try leaving txgain at zero and reducing rxgain to say -10 or -5?

i would be looking at a much lower level first as you shouldn’t need to reduce your gains that much … the other end won’t hear you.

check for interrupt issues, is the mainboard suitable (PCI revision), anything sharing ? what output do you get from zttest ?

i had awful echo problems with a TDM02B, nothing, but nothing seemed to work. moved the card to another box, (almost) clean as a whistle.

Motherboard = Gigabyte GA-8I848P775-G

Digium cards: TDM400P

PCI Revision =

Two Digium cards

On PCI slot’s 2 & 3 (reading from the top down).


Is it worth using fxotune?

Always use fxotune. Sometimes it does wonders…

Are you sure ? Anyone could confirm ?

Hi there

First you need to make sure that your echo canceller is turned on, this is done in zapata.conf. set echocancel=yes, and echotraining=yes.

You can also try aggressive suppression or try another echo canceller. This involves going to the zaptel source folder and editing (if i recall correctly) zconfig.h. You can define one of several echo canceller routines (ONLY one) and if you are using mark2 you can also define aggressive echo cancellation below. That adds a longer ‘tail’, uses more CPU but i’ve found it helpful when dealing with annoying echoes. After changing any of these settings, you must recompile and reinstall Zaptel. To do this- shut down asterisk and unload zaptel. then do make ; make install. it will compile and install. reload zaptel and start *.

zttest and fxotune are two different things.

zttest tests the accuracy of the timing interface with IRQ interrupts. If this fails you will have problems with conferencing and MOH.

fxotune calibrates the port voltages for your line. This makes the port adapt itself to the line to use the right gains, except it is automatic so it si far more accurate than rxgain/txgain. This probably will help you.

Hope that helps!