Zaptel causing Asterisk to not start


I installed asterisk (using trixbox) a few months ago and all has been working fine until I went to add an IAX trunk.
When I added the trunk asterisk needed the zaptel libraries, which I compiled in with seemingly no problem (the zaptel service starts fine).

The problem starts when I try to start asterisk, it fails with the following error:

Sep 6 22:36:42 VERBOSE[10719] logger.c: []Sep 6 22:36:42 WARNING[10719] loader.c: cannot open shared object file: No such file or directory
Sep 6 22:36:42 WARNING[10719] loader.c: Loading module failed!

Now, is in /usr/lib and in /usr/lib64 and I’ve tried linking it into other places in a failed attempt to make it work but with no avail.

Does anyone have any suggestions? I just can’t work out why asterisk can’t see the lib file - i’ve tried rebuilding zaptel with various versions all to the same effect.



i woudl try the following, just to be sure…

rm -f /usr/lib/asterisk/modules/*
cd /usr/src/zaptel
make clean; make; make install;
cd /usr/src/asterisk
make clean; make; make install;

if you’re still getting errors after that, post your distro, kernel version, and a the output from asterisk -vvvc when you attempt to start and we’ll go from there.

Thanks for the reply.
I’ve managed to fix the problem. I realised that the zaptel drivers were being compiled using the 64bit complier, so I just downloaded a 32bit rpm (from … 6.rpm.html) and forces the installation over the existing one and it’s fixed the problem as far as I can see.