Yet on hold starts, then stops?

I found a few posts on this board from people with the same or similar problems…unfortunately, none of their solutions worked for me.

I’m using AsteriskNOW Beta 6 with the default hold music. If I make or receive a call with my VoIP provider and put it on hold, the music cuts out at some point. It’s never at the same time. Sometimes it’s after two seconds, once it hit two and a half minutes before it cut. After it cuts, I can wait as long as I like, take them off hold, and put them back on, but it eventually cuts out again.

If I call an extension within the local network and put it on hold, it works fine. Server load is 0.03. I have silence detection disabled. There doesn’t seem to be any limit on how long calls can be, if they’re not on hold.

If anyone could make a suggestion, that would be great :smiley:

I discovered that when the problem happens, the following line fills the console:

WARNING[12794]: rtp.c:887 ast_rtcp_read: RTCP Read too short


What handsets are you using ? This is a problem with aastra and proberly others if not configured correctly.


I’ve tried with a softphone, a Linksys handset, and a standard phone on an analog phone line.

I just tried switching the MOH to use mpg123, and the problem still occurs…again, ONLY for calls made with my SIP provider. Local calls within the network are fine.