X100P calls out, but can't call in

Hi all…

I’m running Asterisk built from source. I’ve been playing around with SIP calls for a while, it works fine. Yesterday I finally connected a POTS line to the X100P clone card I installed a while ago. After sorting out the interrupts, I can make a call out on the analog line from my WiFi SIP phone, works perfectly and sounds fine. This indicates to me that the hardware and drivers are probably OK… at least most of the way.

Calling in on the analog line is another story. Any time I dial the number it rings once, answers and immediately hangs up. Asterisk never sees the call - I have tried this while watching the * command line with debug on, it’s completely silent during the whole thing. I tried stripping down the extensions.conf to the bare example in *:TFOT, no joy. I have also tried fxs_ls, fxs_ks and fxs_gs with no improvement - groundstart didn’t work at all, the drivers wouldn’t even load. I tried newer zaptel drivers. Compiled & installed zaptel-1.4.3, no change. I did searches on Google as well as the FAQ, knowledge base, etc with no hits for this particular problem. The X100P is using IRQ 12, and nothing else is.

Here are the relevant files…


fxsls=1 loadzone=us defaultzone=us


[channels] ; hardware channels ; default usecallerid=no hidecallerid=no callwaiting=no threewaycalling=no transfer=no echocancel=yes echotraining=no immediate=no context=incoming signalling=fxs_ls group=1 channel => 1


[incoming] exten => s,1,Answer( ) exten => s,2,Echo( )

The system is an AMD Athlon XP 2600+ with 2GB of memory, running Fedora Core 3 with kernel 2.6.12-1.1381_FC3. CPU load is close to nothing, the system isn’t doing much other than DNS and mail.

Suggestions (other than not using an X100P)? Am I missing something?

In zapata.conf the context for the x100p seems to be “incoming”, this context has to be defined in extensions.conf.


My bad; it was “incoming” in both places. I cut & pasted the extensions.conf from the PDF manual, not my own config since I’d already restored my original extensions.conf that I have been using for SIP. The extensions.conf seems to make no difference; I’ve tried my own as well as the stripped-down example. From the CLI I can watch the progress of any SIP or outgoing POTS calls, but an incoming POTS call never seems to even get to Asterisk; nothing is displayed on the console when the line rings, answers or immediately disconnects, even with debug on.

maybe the card is b0rked?

Well, that’s always a possibility. With nothing to compare it to, it’s hard to tell. I was looking here to see if people had any other ideas.