X-lite connection problems

Without going into too much preliminary details, I was setting up freepbx earlier today and could not get the trunk to register for anything so I decided to ditch the GUI. I setup a fresh CentOS 5.2 Server and a fresh install of Asterisk 1.4.22
My Asterisk Server and my client running x-lite are both on the same subnet. I was able to setup a sip extension in freepbx and connect from the client but I am not able to connect to a sip extension from the client under CentOS w/Asterisk. I get a timeout error from x-lite while trying to register.
I am pretty sure that all you need is the extension context in the sip.conf in order to register the x-lite softphone. I know I need to setup extension context in the extensions.conf for telling Asterisk how to send calls to/from the extension context in the sip.conf file but I am trying to take things one step at a time and get x-lite to register before I worry about routing calls to/from it.

Any help is appreciated.

When you did your fresh CentOS install, did you configure SElinux properly? Turn off the firewall settings and try that.

That fixed it. I did not look there because it was a fresh install of linux and I opted to not set selinux or iptables active during the install but then I ran yum -y update and this must have turned the security features back on.

Thanks for the help.