Wrong domain in INVITE


I’m unable to make a call, I investigated a bit and I’ve found that asterisk sends the host domain instead of the one supplied in the conf.

The conf is:

fromuser = +39....@ims.vodafone.it
secret = *************
domain = ims.vodafone.it
fromdomain = ims.vodafone.it                                                       
host = voip1.fixed.vodafone.it

But I see the INVITE going out as:

INVITE sip:39...@voip1.fixed.vodafone.it SIP/2.0

I’m running Asterisk 16.2.1 on Debian

Any 4xx definite response failure from the carrier ?, can you please post the full SIP trace


I noticed that the carrier ignores the domain part in the INVITE, the problem was a wrong dialplan.
Anyway, it’s weird that the outbound proxy address is sent as domain.

Hi all,

I switched to PJSIP and now even the REGISTER is sent with the wrong hostname.
This is the pjsip.conf:

type = registration
retry_interval = 20
max_retries = 10
expiration = 120
transport = transport-udp
outbound_proxy = sip:voip1.fixed.vodafone.it
outbound_auth = vodafone-auth
client_uri = sip:+39...@ims.vodafone.it
server_uri = sip:ims.vodafone.it
;from_domain = ims.vodafone.it

type = endpoint
context = sipin
rtp_symmetric = yes
force_rport = yes
rewrite_contact = yes
from_user = +39...
from_domain = ims.vodafone.it
auth = vodafone-out
outbound_proxy = sip:voip1.fixed.vodafone.it
outbound_auth = vodafone-auth

but the REGISTER is sent as:

REGISTER sip:voip1.fixed.vodafone.it SIP/2.0 and I got a SIP/2.0 480 Temporarily Unavailable back

For the outbound proxy loose routing likely needs to be enabled, which is done by adding “;lr” to the end.

1 Like


I’ve put it in the registration section, I wonder if it needs to go also in the endpoint

Yes, it will. Loose routing preserves the request URI.

Just as reference for futures readers

The proxy URIs have the “lr” parameter added. This is because most proxies these days follow RFC 3261 and are therefore “loose-routing”. If you don’t have it set, you’ll probably get a 404 response from the proxy. The "\" before the semicolon is important to keep the semicolon from being treated as a comment start character in the config file.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.