What do I need?


I have successfully gotten Asterisk Setup using Broadvoice. I can place and receive calls after about 48-hours of tinkering. Anyways, I am starting up a HelpDesk company and I have some questions about what more I need.

Currently I have a Broadvoice unlimited business account with a Primary number and then an Alternate toll-free number. When I call the Toll-Free number, basically all it does is forward to my primary number. This is fine i guess, because it works. I can also take 2 calls at a time or place 2 calls at a time.

Now, what i need is a queue type system so that when customers call in, there call will ring to an Agent if one is avail. If an agent is not avail then it will go into a Queue and wait until an agent is avail.

Asterisk can do this correct? I have a feeling I will need to have some more phone numbers or something like that? Or possibly one phone number with the ability to have like 10 calls in place at the same time? If so, where can i get something like this?

Or is this just not how its done?

Thanks for the help, this whole system is really cool once you get the hang of it!

Try orderlyq.com/asteriskqueues.html

Cool, great link. That is exactly what i needed.

Now I have done everything from steps 1 through 7.

I have some problems I am hoping you may be able to help me with.

The first problem is that I dont think the whole login part is working. When I dial Extension 2001, it asks me to input my UserID followed by the pound key, I do this and then it waits about 3 seconds and says goodbye, it never asks me for my password. I have a feeling it is because my “context” is not correct in step 6. I have put a whole bunch of different context in there and its just not working.

Another problem I am having is that when I dial Extension 2020 is rings once and then hangs up, does not go into the Queue. (As it should because there are no agents available.)

Again, thanks for that link, if this works i think it will be exactly what I needing!

OK, From looking at the console it seems that the “AgentCallbackLogin” is outdated, so i switched it to just “AgentLogin” and I get the same results. :frowning:

EDIT: Upon Further Investigation it seems that it just is not “seeing” my input. Like when i press the numbers on my phone, the Asterisk Box does not see me press them.

What would cause this?

EDIT2: Upon Further Further Investigation, it turns out that if i set:

[code]member => Agent/6001


member => SIP/6001[/code]

in Queues.conf, i can dial extension 2020 and it will work properly as if the agents are “logged in”

When i run “agent show” it shows both agents are not logged in.

I don’t see AgentCallbackLogin as being outdated - not in 1.4. (But some variables and syntax in the example, if taken literally, certainly are.)

You may want to post agent.conf, queue.conf, and relevant portion of extensions.conf.


maxlen = 0
announce-frequency = 0
announce-holdtime = no
member => Agent/6000
member => agent/6001

agent => 6000,1234,Donald Leatherwood
agent => 6001,1234,Stephen Leatherwood


include = internal
include = QueueSystem
;exten => _17573204234,1,SetCallerID(xxxxx)
;exten => _17573204234,2,Dial(SIP/broadvoice/${EXTEN:1},20,r)
;exten => _17573204234,3,Congestion(5)
exten => _1NXXNXXXXXX,1,SetCallerID(xxxxx)
exten => _1NXXNXXXXXX,2,Dial(SIP/broadvoice/${EXTEN:1},20,r)
exten => _1NXXNXXXXXX,3,Congestion(5)

exten => 6000,1,Dial(SIP/6000)
exten => 6001,1,Dial(SIP/6001)
;Extentsion to test Music
exten => 2000,1,Answer
exten => 2000,2,SetMusicOnHold(default)
exten => 2000,3,WaitMusicOnHold(300)
exten => 2000,4,Hangup

;Agent Login Extension
exten=> 2001,1,AgentCallbackLogin(||${CALLERIDNUM}@TechQueue)

;Agent Logout Extension
exten => 2002,1,AgentLogin(||l)

;Add to Queue Extension
exten => 2020,1,Answer()
exten => 2020,2,Ringing
exten => 2020,3,Wait(3)
exten => 2020,4,Queue(TechQueue)
exten => 2020,5,Hangup

I set up a test very similar to what you have posted and got asked for password and so on. Just curious: from where do you call extension 2001? What’s the value of CALLERIDNUM? (This is deprecated; use function ${CALLERID(NUM)} instead.)

What’s the version of Asterisk?

I am running AsteriskNOW beta 5, which I believe is 1.4.

I have tried calling from both phones 6000 and 6001. Caller ID on both of those are listed as 6000 and 6001 respectively.

I will try what you have suggested, if not I will mess around some more until i get it right. :laughing:

EDIT: I should mention that on mine i have gotten it to ask for a password, but then when i input my password (1234) and then hit “#” it does nothing, it just waits and says goodbye.

I then check the agent queue and it will say no agent is logged in.

OK, i think i know WHAT the problem is, i just dont know how to solve it.

I have setup my voicemail today, but when i try to log into the voicemailbox, it asks me to input my password. I dial my password, the system waits and then tells me login-incorrect and to input it again.

Basically it is doing the exact same thing as try to login as an agent, its not “seeing” or “hearing” my keypress.

My phones are Grandstream GXP-2000.


Ok, i just installed XLite and everything works great.

So I guess its a setting in the phones that may be causing the issue. Anyone have any recomendations?

the phones are Grandstream GXP-2000

EDIT2: I updated the phones firmware to the latest revisions and also changed the codecs.

Neither worked :frowning:


You have the dtmfmode set incorrect in the sip.conf try info for grandstreams.



You have the dtmfmode set incorrect in the sip.conf try info for grandstreams.


That worked!

awesome, thanks for the help everyone!

:smiley: :smiley: :smiley:

nevermind. :frowning:

Now when i goto login an agent to the queue, it keeps saying invalid extension when i am infact entering a valid extension. Basically it accepts my Agent Number and my password, but then It asks me to enter my extension and I enter 6000 (or 6001) and it says invalid extension.

Voicemail on the otherhand is working great.

Ok, i can use AgentLogin instead of AgentCallBackLogin to login, but then as soon as i hangup it logs the agent out.

Observed by watching the console.

EDIT: i had to change my

[code]exten=> 2001,1,AgentCallbackLogin(||${CALLERID(NUM)}@internal)


exten=> 2001,1,AgentCallbackLogin(||${CALLERID(NUM)}@broadvoice-outbound)

although i have no clue why “internal” would not work, at least everything works now!

Again, thanks for all the help.