Weird Sound Problem

I am having some troubles getting a few files to play properly. My provider is VoipStreet and they only support ulaw.

I received my files in wav format and converted them to raw using sox and this command line:

sox -V A.wav -r 8000 -c 1 -w A.raw

my extensions.conf contains the following

include => debug
exten => s,1,Answer ; Answer the line
exten => s,n,Wait,2
exten => s,n,Set(TIMEOUT(digit)=5) ; Set Digit Timeout to 5 seconds
exten => s,n,Set(TIMEOUT(response)=10) ; Set Response Timeout to 10 seconds
exten => s,n(restart),BackGround(A)
exten => s,n,Wait,1
exten => s,n,BackGround(B)
exten => s,n,Wait,1
exten => s,n,BackGround©
exten => s,n,Wait,1
exten => s,n,BackGround(1) ; Play some instructions

Now the weird stuff: Soundclip A plays very well. Before ‘B’ starts, I hear a small ‘sht’ then the file plays fine, at the end I hear another ‘sht’. Same goes for C, 1,2,3, all other files. Does NOT happen for A. I listened to all of them in wav format and that ‘sht’ is not there. Not sure how I can listen to raw files but I believe it won’t be there as well…

If you wanna listen to it…call 1-514-667-3795


why did you convert them to raw? Asterisk can play WAV files, if you are gonna convert them to something convert them to GSM format…

I tried 3 format so far and they all have the same problem

I tried slinear and gsm and both have that small sound before and after.

Right now I am running all the files in GSM format, converted as per the wiki instructions.

If I try playing the wav files directly, it doesn’t work and Asterisk complains:

Oct 31 05:09:32 WARNING[55578]: file.c:436 ast_filehelper: Unable to open file on /usr/local/share/asterisk/sounds/A.wav
Oct 31 05:09:32 WARNING[55578]: file.c:825 ast_streamfile: Unable to open A (format (ulaw)): No such file or directory

obviously the file is there but it can’t process it.


well, I installed WavePad for Windows and played the GSM files back… there really is an unwanted bit at the end. not sure how it got there since it’s not in the original! I’ll edit them out I guess