WebRTC / Websocket not working with iOS


I’ve set up Websocket in my asterisk, I tried both sipML5 and jssip to connect to the websocket.
It is working if I use Google Chrome on my Windows 10 PC, and also if I use Chrome on my Android Phone.
But if I use Chrome or Safari on my iOS device, I am not able to connect to the asterisk server.

I am running Asterisk 16.4.1
The error shown in sipML5 on iOS is: Failed to connet to the server
The error shown in asterisk CLI is:

[2020-01-16 20:22:49] ERROR[3327]: iostream.c:633 ast_iostream_start_tls: Problem setting up ssl connection: error:00000005:lib(0):func(0):DH lib, System call EOF
[2020-01-16 20:22:49] ERROR[3327]: iostream.c:538 ast_iostream_close: SSL_shutdown() failed: error:00000001:lib(0):func(0):reason(1), Internal SSL error

I also get the same error in asterisk CLI if I use Android or Windows, but after the two error message, I get this output if I am using Android or Windows:

  == WebSocket connection from '' for protocol 'sip' accepted using version '13'
    -- Added contact 'sips:1000@;transport=ws;rtcweb-breaker=no' to AOR '1000' with expiration of 200 seconds
  == Endpoint 1000 is now Reachable
    -- Contact 1000/sips:1000@;transport=ws;rtcweb-breaker=no is now Reachable.  RTT: 33.435 msec

But if I use iOS, I only get the two error messages, and not the WebSocket connection accepted messages.

Has anybody an idea, why this isn’t working on iOS devices?

Thanks in advance!

Just a hunch but maybe iOS is enforcing WSS ?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.