WebRTC No remote video for receiving party

Hello,

I have been trying to resolve this issue for some time but have had no success. I have installed asterisk on an AWS EC2 running Ubuntu.

I am attempting to make a video call between two devices using webrtc.

For some reason the remote video stream is only working on the device who initiated the call, the remote stream on the recipients device does not display.

When device 1 calls device 2: Device 1 gets the remote stream from device 2, but device 2 doesn’t get the remote stream from device 1.

When device 2 calls device 1: Device 2 gets the remote stream from device 2, but device 1 doesn’t get the remote stream from device 2.

Why would this be happening?

I have attached the sip trace:
https://pastebin.com/raw/XiddY1Cv

Asterisk did set up the video stream. As you have no time stamps (screen scraped, rather than log file?) I can’t tell if the BYE was immediate, or not. An immediate BYE would indicate that the originating didn’t like the type of video stream it actually got.

Actually, there is a possible problem, but the logging doesn’t confirm or deny it. The terminating side has only accepted VP8 and VP9, but the originator was offered H264 as well. If it tried to send in H.264, Asterisk would have to drop the frames, as it cannot transcode video. You should restrict the allowed codecs to those acceptable to everyone (although I think there are some options for restricting codecs at run time).

Hi @david551,

Really appreciate your help with this, I have attached a log file with TS’s:

https://pastebin.com/raw/511pQJrM

note that I initiated the BYE request, the call doesn’t terminate unless I initiate the BYE.

I tried removing some of the codecs but I still have the same issue, I also tried using only VP8:

[webrtc_client2]
type=endpoint
aors=webrtc_client2
auth=webrtc_client2
dtls_auto_generate_cert=yes
webrtc=yes
context=customers
disallow=all
allow=ulaw,alaw,gsm,vp8
dtls_setup=actpass
use_avpf=yes
ice_support=yes
media_use_received_transport=yes
rtcp_mux=yes