Asterisk with WebRTC : no remote video when i answer call


#1

Hi to all,
sorry i am facing, since more than 4 days, a real problem with video call with WEBRTC.
i have tested over asterisk 15 and later with 16. either in public IP and local. but i always get same result:

  • audio is OK both sides(caller and callee)
  • video is OK caller side
  • video (remote video) not OK callee side
    Even when i test with CMP2K , same result . no remote video but local video is always OK
    i suspect problem coming from my asterisk config or system. because all WebRTC js libraries (SipML5, jsSIP, SIP.js) from their tests pages have same results too.

So perhaps i’m missing something

here is my configs and logs


thanks and sorry for my bad english


#2

again me.

as stated in the previous post, i suspected asterisk to the probleme. i installed other PBX which runs without any problem and without changing anything from my scripts.

but i’d like to steak on asterisk because that’s what i master better and i can’t change it. so waiting for you to point me on the right direction
thanks


#3

Just wanted to shout out that you are not alone!
Guessing this is yours also? https://groups.google.com/forum/#!topic/sip_js/wBDosxzEBXk

When I started using this a few months back had issues in FireFox but Chrome was working fine.
Now having issues with Chrome but FireFox is working fine.
I.e. one way video - from a Wireshark trace it seems that only one video is being sent back by asterisk.

Same result with CMP2K; using pjsip and latest asterisk and browser version for Windows.
Tricky to know if this a browser problem or Asterisk. Video in WebRTC has been very temperamental from the get go though. Audio working fine as always.


#4

Hi,

Problem is because of SDP format change. Asterisk and Firefox supports Unified Plan and previous versions of Chrome before 71. supports Plan B. New version of Chrome supports experimental version of Unified Plan which is recommended for WebRTC. In the interim you can use sdp-interop to support both Firefox and Chrome.

Ravi


#5

Hi Ravi,

Yes this post is mine on sip.js forum. I didn’t see how to resolve the problem but perhaps I will try Sdp interrop suggested . Because I see in pjsip debug that asterisk do and complete ice trickle and Rtp packets flow back and forth. But video rtp seems to be sent at bad address . I have since change ippbx but it gives me lot of work to because I must change all the script ( sub routines, agi, ari monitoring , etc … ) . I use Astérix since at its early version so now I waste my time learning new concept loool . Hope a solution will be proposed .


#6

Been forcing Chrome to use unified plan which should be stable now (or so I thought). Thanks will retry with interop but had little luck.

Thing is CMM2K uses interop but has since started failing. Does feel like a browser issue rather than asterisk.


#7

It’s entirely possible that the browser has changed things and requires modifications in Asterisk to work with once again (as is often the case). I don’t have a time frame on when this would get looked into though, but it is of interest.