WEBRTC chrome v 35 now using DTLS[solved]

I get error Unsupported fingerprint hash type ‘sha-2’ received on dialog, since chrome is now using DTLS instead of SDES tls, all webrtc connections don’t work anymore, tried configuring siphtml5, sending correct para meters to asterisk , dtls is configured but still don’t work, any idea of workarounds besides Doubango.

any input is well appreciated :open_mouth: .

thank you.



Thank you navaismo, i had looked at those links on friday, did installed a test asterisk with 11.7, 11.9 and 11.1.2 and dtls kind of work since no errors (only on 11.7 patched) but now rtp was not flowing which was the main issue we moved to version 12 on pjsip.

we had configured support for dtls on 12, but get same issue, actually there is no method on chrome to only send sha 1 which also could solve the problem.

did you have any luck solving this issue ?

Thank you navismo we were able to solve the issue by disabling dtls on the app by running the command stated on the forum {‘mandatory’: {‘DtlsSrtpKeyAgreement’: ‘false’}}

it works good and confirmed that works on v 37 the only caveats is that for v37 we will have to add a external signed certificate since self-signed certificate are not longer accepted.

Thanks for sharing this will help a lot people.