Webrtc - Call dropping after 1 minutes


#1

Hi,

I am getting this error in CLI…Anyone plz help me on this to solve
this issue:

In WebRTC sipml5 call drop after exactly 1 minutes…

Connected to Asterisk 15.6.1 currently running on ip-10-0-1-66 (pid = 10058)
[Sep 25 10:57:46] ERROR[7059][C-0000000a]: res_rtp_asterisk.c:2880 __rtp_recvfrom: DTLS failure occurred on RTP instance ‘0x7f46bc0e8648’ due to reason ‘sslv3 alert unexpected message’, terminating
[Sep 25 10:57:46] WARNING[7059][C-0000000a]: res_rtp_asterisk.c:6602 ast_rtp_read: RTP Read error: Unspecified. Hanging up.


#2

Are you using chan_pjsip? If so, have you set the dtls_rekey setting to 60? If so that will attempt to renegotiate the TLS session. Failing that renegotiation will stop the call. I’m not sure why renegotiation would fail though. Have you tried different browsers?

If that value is set and you don’t need it then as a work around you can set it to 0 (the default), which should disable it.


#3

thank you @kharwell . It worked


#4

I need to know why i am getting this response from CLI in asterisk Webrtc while the extensions are registered and idle and the solution to avoid this

[Oct 6 06:37:55] ERROR[1598]: chan_sip.c:4274 __sip_reliable_xmit: Serious Network Trouble; __sip_xmit returns error for pkt data
[Oct 6 06:37:58] ERROR[1598]: chan_sip.c:4274 __sip_reliable_xmit: Serious Network Trouble; __sip_xmit returns error for pkt data


#5

The most likely cause is there is no valid route to the IP address you are using.


#6

Thank you for your response @david551
but we are using domain instead of IP in webrtc development and the service hosted in amazon cloud


#7

The way that low level network I/O works (and this a low level failure), is that the domain name is looked up to get an IP address, and the IP address is then used for the low level operations. For UDP, the IP address can be specified for each request, or can be specified at the beginning of a session. I can’t remember which Asterisk. uses. For TCP it can only be specified at the beginning of a session. Translating a domain name to an IP address is an expensive operation and not something you are going to do 50 times a second, even when using UDP for media.

Note if there is no audio in the first minute, it probably means there never was a valid route to the IP address agreed as the media destination.

I’m not sure if destination unreachable responses from routers or the end system will also produce this error, given that they are asynchronous.

Incidentally, although I haven’t used WebRTC, the general advice on this forum is that you should not even think of using WebRTC unless you have a thorough understanding of the underlying technologies. WebRTC is neither stable in time, not suitable as a plug and play technology for new users. It is fairly clear that you have only a sketchy knowledge of even basic TCP/IP.