Voicemail to Email

I am trying to set up voicemail to be sent to my email on my Trixbox Asterisk system but it isn’t working. I have no way of knowing what the error actually is because I don’t know how to access any logs or the local email messages. Can anyone tell me how to access these? I ended up installing the sendmail program because I thought it might not be installed. That didn’t work. I have an smtp server entered along with fqdn. I have tried to install Webmin to manage this but I can’t access it without a web browser. So I tried to install Firefox on the machine but am having errors when I try to run it. I really just need to know what the root problem is, so if anyone could tell me how to access any log files that might tell me or how to read the email that my machine tells me I have when I log on, I would appreciate that.

Check /var/log/maillog

Ok, I found the maillog and how to access the local mail. However, I don’t see anything suspicious. Could anyone send me what the maillog should show when an email gets sent out successfully from the voicemail system?

Asterisk uses Sendmail.

A good practice to get into is to edit the /etc/mail/mailertable and point all users@yourdomain.com to your mail server directly. It’s then acting as a smart relay host for recipients in that domain. Do that and restart sendmail and see if that helps. Make sure your mail server is allowing relaying from your Asterisk addy first though or you’ll be chasing your tail.

good morning
I tryed to do this on the mailertable but i don’t have access to this file. I don’t understand what i shoul do to receive emails :’(

What do you mean you don’t have access to the file? You are the root, right?

Good morning

Well here is exactly my problem:

In the file /etc/hosts:

Do not remove the following line, or various programs

that require network functionality will fail.

127.0.0.1 localhost
127.0.0.1 asterisk1.local

(after having done this modification, every time i restart my pc it returns an error when starting “Impossible To look for Internet Adresse of localhost.localdomain. This will prevent GNOME from fonctionning correctly. It is possible to repair this problem by adding localhost.localdomain in /etc/hosts file” too choces are given whether retry or get connected inspite of the problem, when i clik on get connected, i can connect to internet.)

Well, concerning the resolv.conf file:

#generated by /sbin/dhclient-script
nameserver
nameserver
search localdomain
~

this file is generated automatiquely and it is not me who configurated it.

In /etc/mail/sendmail.mc file, the unique modification I did is to to write the name of my SMTP server

define(SMART_HOST',smtp.My_provider.tn’)

this all the configuration I did
then i restarted the service by the command :
service network restart.

When trying to send a mail this is what was shown:

[root@localhost ~]# sendmail -v My_id@hotmail.com
salut
My_id@hotmail.com… Connecting to [127.0.0.1] via relay…
220 localhost.localdomain ESMTP Sendmail 8.13.7/8.13.7; Mon, 14 May 2007 16:59:53 +0100

EHLO localhost.localdomain
250-localhost.localdomain Hello localhost [127.0.0.1], pleased to meet you
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-8BITMIME
250-SIZE
250-DSN
250-ETRN
250-AUTH GSSAPI DIGEST-MD5 CRAM-MD5
250-DELIVERBY
250 HELP

MAIL From: SIZE=6 AUTH=root@localhost.localdomain
250 2.1.0 … Sender ok

RCPT To:
DATA
250 2.1.5 … Recipient ok
354 Enter mail, end with “.” on a line by itself

.
250 2.0.0 l4EFxrwa003929 Message accepted for delivery
My_Id@hotmail.com… Sent (l4EFxrwa003929 Message accepted for delivery)
Closing connection to [127.0.0.1]

QUIT
221 2.0.0 localhost.localdomain closing connection
[root@localhost ~]#

And always nothing arrives at my mailbox :open_mouth:
I don’t know what i should do with the mailertable, it is an empty file!
What should I do? Please utrgent help :confused:
Khawla

You may simply be a victim of spam filters.

Many spam filters look to see if the sender is root@localhost.localdomain

If they are, they reject that message as spam.

Try turning off spam protection in your email account to test that.

I think that if there is no problem in my configuration, the root@localhost.localdomain should be root@My_DNS_Server no??
And on my account root@localhost.localdomain ??
I really do not understand what is the problem :confused:

If you did not name the machine, or did not setup your sendmail correctly to use your machine name, then it will default to root@localhost.localdomain.

Spam filters frequently delete messages from that sender. Just because you receive some spam, doesn’t mean that your voicemail messages are not being deleted by a spam filter. Spam filters are not perfect.

Just try shutting off spam protection and see what happens

Setting up sendmail isn’t really a question about Asterisk. You should really search for internet forums that support sendmail.

How to do this?

[quote=“dufus”]Spam filters frequently delete messages from that sender. Just because you receive some spam, doesn’t mean that your voicemail messages are not being deleted by a spam filter. Spam filters are not perfect.

Just try shutting off spam protection and see what happens [/quote]

I put the filtering level to zero but always nothing. I even tried on different accounts(hotmail, gmail, yahoo,…) but it is really always the same result

All that I found about configuring sendmail is what I did.

You should never have this entry in /etc/hosts. Usually you don’t need any other entries than localhost. But if you really, really want to make sure that sendmail picks up the correct domain name, you can put your actual IP address (not 127.0.0.1 - which should always be localhost) and domain name in there.

Just wondering: after you have modified this file, have you run m4 to actually reconfigure sendmail and restart? You can do

$ grep '^DS' /etc/sendmail.cf to find out if smart host is picked up.

[quote=“valley”]
you can put your actual IP address (not 127.0.0.1 - which should always be localhost) and domain name in there.[/quote]
do you mean that i should do like this?

[code]# Do not remove the following line, or various programs

that require network functionality will fail.

127.0.0.1 localhost
192.168.137.144 localhost.localdomain asterisk1.local
[/code]

[quote=“valley”]$ grep '^DS' /etc/mai/sendmail.cf to find out if smart host is picked up.[/quote]
yes it is OK it returned DSsmtp.“myprovider”.tn

I did these changes and always nothing!

the problem was resolved :smile:

[code]# Do not remove the following line, or various programs

that require network functionality will fail.

127.0.0.1 localhost
192.168.137.144 mycompany.com asterisk1.local
[/code]