Voicemail for incoming calls from FXO


I have setup an asterisk server with an FXO card and an 2 x IP Phone (one SIP and one sccp), all calling works fine.
I also setup voicemail for the sccp phone and that seems to work fine when I’m calling from the SIP phone. However, when a call comes in from the FXO (into ‘incoming’ context) it just keeps ringing and doesn’t fall back to the voicemail system (when I pick up, the call works fine).

Here’s my extensions.conf:



exten => s,1,Dial(SCCP/6004)

include => outgoing

exten => 6004,1,Dial(${HomePhone},10)
exten => 6004,n,VoiceMail(6004)

exten => 1000,1,Dial(${SoftPhone})

exten => 700,1,VoiceMailMain(s${CALLERIDNUM}@default)
exten => 700,2,Hangup()

exten => _0.,1,Dial(${OUT}/${EXTEN})
exten => _#.,1,Dial(${OUT}/${EXTEN})

No funky stuff i would say, so I was wondering what I am missing to get the voicemail working for calls coming in over FXO.



Could be that I’m wrong, but I’m missing the line where you tell incoming to go to the voicemail.


exten => s,1,Dial(SCCP/6004)
exten => s,n,Voicemail(6004)
exten => s,n,Hangup

Hope this helps.


Yes, I’m indeed not havind that. I was under the impression that it would be enough to just send it to the right extention and letting it pass from there to the voicemail (like exten 6004 has it’s “voicemail” line).

But I guess that might indeed be my problem :stuck_out_tongue:

Just so you know, i tested it with the voicemail line added to the [incoming] and working great now!

Thanks again,

Hi All

Hope this is the correct are for this question as it was the only one mentioning voicmail.

Im new to asterisk so i dont know the system too well. I have the system 100% but I am having difficulties retrieving voice mail. The voicemail password is specified in “Voicemail and Directory” area, but when dailing *97 or *98 you are asked foe the password. Even if the password is entered, the prompt continues asking for password.

What am i doing wrong.

You would need to tell us more about your voicemail.conf file. Perhaps too this is a matter of your phone’s settings. I had to add this line under the extension in my sip.conf to get Asterisk to recognize key punches from my IP phones: