Voicemail answering messages


#1

I have recorded my messges that will be played to a caller e.g. for unavailable, but an incoming caller hears both my message and following that the standard female announcer repeating most of what I’ve just said (“Leave a message after the tone etc”). How can I get he system to only give my message before recording?

Thanks

Paul


#2

The most obvious fix is to simply leave those things out of your spoken message since you know it’s going to be in ‘vm-intro’ anyway.

Assuming you’ve built it from source, you can comment-out line 2462 in app_voicemail.c and rebuild the voicemail module. That will get rid of the message all right, but it may effect some other things.

        if (!res && !ast_test_flag(options, OPT_SILENT)) {
                // the line below normally plays the intro
                // res = ast_streamfile(chan, INTRO, chan->language);
                if (!res)
                        res = ast_waitstream(chan, ecodes);
                if (res == '#') {
                        ast_set_flag(options, OPT_SILENT);
                        res = 0;
                }
        }

Hey, maybe you know the answer to this: Once a new unavailable message is set, how does one get rid of it?


#3

Uhhh - I’d hoped it was somewhere in an obscure conf file.

Thomastim - you probably know most of this already but in the interests of help to others I’ll start at the beginning:
(assuming message box 9999)
If you use the addmailbox script (which I couldn’t find and had to download seperately) you will produce a directory called /var/spool/asterisk/vm/9999 which contains some default gsm files and a INBOX subdirectory. The example 1234 mailbox from voicemail.conf has not been automatically generated.
Interesting I think if you now try to use this mailbox you get the OMINOUS SILENCE (but a message is still recorded)
Now you can record your message.
Your messages live in: /var/spool/asterisk/voicemail/default/9999
The files look like unavailable.gsm, uavailable.wav and unavailable.WAV and are the same thing (I think) in all the formats specified in voicemail.conf. There already is a directory for 1234. More interesting IT IS ONLY YOUR MESSAGE i.e. the irritating default voice is not at the end of it - so the system must glue two audio files together to give the unavailable response - this is why I assumed that there must be an easier way than changing the makefile.
All I did was to delete ALL the unavailble files in /var/spool/asterisk/voicemail/9999 and rerecord - brutal, but it worked.

Paul


#4

if you call voicemail with the ‘s’ option, it skips the instructions.

voip-info.org/tiki-index.php … +VoiceMail


#5

Thanks Baconbuttie - I think we can call that resolved now

Paul


#6

Sorry about that PaulL, somehow I missed that one even though I was looking right at the flags right in the code.