Voicemail and G.729


#1

Hi

Is it possible to use G.729 pass-thru mode when recording or playing voice message

Any comment is welcome


#2

Provided that your recording format is G.729 and your playback source files are G.729-encoded files, sure.


#3

Ok

I configured voicemail.conf as defined in http://www.voip-info.org/wiki/view/Asterisk+G.729+pass-thru
voicemail.conf

[general] format=g729 maxsilence=0
I can hear voicemail annonce in G.729
but I cannot record mail

see log below

[quote]
– <SIP/680-00000019> Playing ‘vm-intro.g729’ (language ‘en’)
– <SIP/680-00000019> Playing ‘beep.g729’ (language ‘en’)
– Recording the message
– x=0, open writing: /var/spool/asterisk/voicemail/default/888/tmp/UtgO5i format: g729, 0x23bc928
[Sep 20 17:50:25] WARNING[3932]: format_g729.c:78 g729_write: Invalid data length, 2, should be multiple of 10
[Sep 20 17:50:25] WARNING[3932]: file.c:173 ast_writestream: Natural write failed
[Sep 20 17:50:25] WARNING[3932]: app.c:890 __ast_play_and_record: Error writing frame[/quote]

What is the problem?
Is there some others parameters to configure ?


#4

What’s the packet size that you’re phone’s sending? Try setting it to 20ms.


#5

Thanks for the help

I use AAstra 55I phone and the ptime was set to 30ms by default , when I changed it to 20 ms it works

I can leave message and play recorded messages with G.729 codec


#6

Yay :smile:


#7

Hi

I have another issue now when I selected on AASTRA phone both codecs ( G.711u and G.729) with ptime = 20 ms
I get the same problem

herafter the Asterisk CLI log with sip debug enabled


#8

Hi
I made another test
when configuring G729 before G.711u ==> it works

Why asterisk behave differently according to the codecs order ?