(?) using asterisk only local lan

Hi,
I have server (Suse 10.2) and installed asterisk 1.4.xx. On server run kiax (Phone 41) and on client (Suse 10.2) run kiax (Phone 40).
It rings on server, If the number 41 is dialed from Phone 40, but no rings from Phone 41 to Phone 40…why? :open_mouth:
I have only this files in /etc/asterisk:
logger.conf
sip.conf
iax.conf
extensions.conf

Bellow are my kconfigurations

Kiax>>Settings on Client:
Account name: Phone 40
IAX Server: 192.168.1.80
Username: 40
Pasword: 40
CallerID Name: Phone 40
CallerID Number: 40
x GSM
x Make account default

Kiax>>Settings on Server:
Account name: Phone 41
IAX Server: 192.168.1.80
Username: 41
Pasword: 41
CallerID Name: Phone 41
CallerID Number: 41
x GSM
x Make account default

=========================================================================
Connected to Asterisk 1.4.17 currently running on sponge (pid = 5468)
Verbosity was 0 and is now 3
sponge*CLI>

vi /etc/asterisk/logger.conf

[general]

[logfiles]
console => warning,error
messages => notice,warning,error

vi /etc/asterisk/sip.conf

[general]
context=default
bindport=5060
bindaddr=192.168.1.80
srvlookup=yes

[30]
callerid=Phone 30
host=dynamic
domain=192.168.1.80
user=30
secret=30
type=friend
mailbox=30
nat=yes
canreinvite=no

[31]
callerid=Phone 31
host=dynamic
domain=192.168.1.80
user=31
secret=31
type=friend
mailbox=31
nat=yes
canreinvite=no

vi /etc/asterisk/iax.conf

[general]
bindaddr=192.168.1.80
context=default

[40]
type=friend
username=40
secret=40
host=dynamic
callerid="Phone 40"
mailbox=40
notransfer=yes

[41]
type=friend
username=41
secret=41
host=dynamic
callerid="Phone 41"
mailbox=41
notransfer=yes

vi /etc/asterisk/extensions.conf

[general]
static=yes
writeprotect=no

[lokal]
exten => 30,1,NoCDR()
exten => 30,2,Dial,SIP/30|55|Ttr

exten => 31,1,NoCDR()
exten => 31,2,Dial,SIP/31|55|Ttr

exten => 40,1,NoCDR()
exten => 40,2,Dial,IAX2/40|55|Ttr

exten => 41,1,NoCDR()
exten => 41,2,Dial,IAX2/41|55|Ttr

[default]
include => lokal

Thanks…

hi

try use bindaddr 0.0.0.0

cheers
smaikol

[quote=“smaikol”]hi

try use bindaddr 0.0.0.0

cheers
smaikol[/quote]

Hi,
I have changed by sip.conf and iax.conf to:
[general]
bindaddr=0.0.0.0
and made reload.
sponge*CLI> module reload
But the problem is like before.

And I’m not understand now…The kiax (server with Phone 41) also rings when I dial from client (Phone 40) although the asterisk is disconnected.
spongeCLI> stop now
sponge
CLI>
Disconnected from Asterisk server

Thanks…

Well, generally speaking it’s not a good habit to put a client for calls on the same ip ov the server. Try insteda to put 2 different softphone on the same client machine and test it.

i suggest you to try with the zoiper softphone, its’ free multiplatform adn muliprotocol so it could be a good testing help for you.

if you still get disconnected from the server then maybe it’s an installtion problem.

cheers
smaikol

Hi,
Zoiper is downloaded. I installed the samples from the asterisk (make samples) and continue using my own test files: sip.conf, iax.conf, extensions.conf and voicemail.conf. I can now dial the sip-number from iax-number (vise versa) on one computer and also from another computers.
Thanks.