Upgrading breaks asterisk! can't start


#1

when i attempt to start asterisk, i get the following error:

[ Booting…Nov 25 16:50:22 NOTICE[2482]: cdr.c:1185 do_reload: CDR simple logging enabled.
Nov 25 16:50:22 WARNING[2482]: loader.c:325 __load_resource: /usr/lib/asterisk/modules/chan_modem.so: cannot open shared object file: No such file or directory
Nov 25 16:50:22 WARNING[2482]: loader.c:499 load_modules: Loading module chan_modem.so failed!

i was running 1.0.9 and tried to upgrade to 1.2 using the tarballs from the digium site. I installed asterisk, zaptel, and asterisk-sounds in that order. anyone have any ideas? i’m not really sure what i did wrong or what to do next.


#2

figured the problem out; that module is deprecated. reconfigured asterisk using new config files and everything works great.

now codec translation no longer works, however. i get the following:

Nov 25 18:35:20 WARNING[22851]: channel.c:2675 ast_channel_make_compatible: No path to translate from SIP/540-a887(4) to SIP/starvox-46a2(256) Nov 25 18:35:20 WARNING[22851]: app_dial.c:1556 dial_exec_full: Had to drop call because I couldn't make SIP/540-a887 compatible with SIP/starvox-46a2


#3

turns out when you re-install you need to re-install/reregister the 729 codec.

all better now.