Upgrade to 1.2 - No longer reading dialed extension


#1

Hello,

I have an Asterisk box connected to a Nitsuko PBX via a T1 interface card. I was running V 1.09 of Asterisk and everything worked well, when I dialed a 3 digit extension (eg. 201) on the trunk from the Nitsuko, asterisk read the dialed extension and passed the call to a SIP phone.

The new version (1.2) behaves somewhat differently. The very first call I make on the trunk line will work just fine. The problem is that every subsequent call will route to the first extension that was dialed. I have tried several different trunk lines on the T1, but I still get the same results. For example if I dial 204 for the very first call after restarting Asterisk all subsequent calls to the 2XX series (eg. 201) will go to 204. In fact as soon as I hit the 2, 204 will be called. If I then try to dial a 3 on the trunk (I do not have any 3XX extensions on the Asterisk Server) it will come back and say "Unknown extension ‘304’ in context ‘nitsuko’.

Where is it storing these second two digits? How do I clear it for the next call. I must admit I am at a bit of a loss here.

The relevant portion of my extensions.conf (The same one that worked with V1.09):

[nitsuko]

exten => _2XX,1,Dial(SIP/${EXTEN},20,Tt)
exten => _2XX,2,Hangup
exten => _2XX,101,Voicemail(b${EXTEN})
exten => _2XX,102,Playback(Goodbye)
exten => _2XX,103,Hangup

Any help would be greatly appreciated.
Thanks,
Ted


#2

I’ve been runing the lastest head prior to 1.2, and I had similar problems in that it occured after I had used background (it invites users to enter an extension) It’s almost as if it only wants to accept one digit. I’ve gotten around this by using an * as an escape character, so for extension 200, the user inputs *200

That said, having upgraded to 1.2, it now works as expected

Have you tried using the WaitExten() function? It may be it’s timing out on the input before the extension can be fully entered.

rgds


#3

Thanks for the idea. You are correct, if I enter and * before the extension number everything seems to work fine.

This sounds like a bug to me, however I find it odd that your problems went away with 1.2.

Does anyone else have any insight on this before I submit it as a bug. I would hate to be overlooking something obvious.

Ted