unixODBC and FreeTDS and Asterisk compilation error


#1

Hello,

I am trying to install unixODBC-2.2.9 and freeTDS0.62.4 I have now tried this on three different system, and during and after various rebuilds and installs on RedHat V9.

I have had some varying and limited success. Twice I have had this working, both cdr_tds.c and cdr_tds.o However, I cannot replicate the setup again, I have tried time and time again, on new build, fresh installs and older installs alike.

Both the unixODBC and the freetds seem to compile correctly, when I attempt to compile asterisk, I get the following error,

/usr/include/sqltypes.h:51:69: operator ‘||’ has no right operand
res_odbc.c: In function odbc_obj_connect': res_odbc.c:481: warning: passing arg 5 ofSQLGetDiagRec’ from incompatible pointer type

make[1]: *** [res_odbc.o] Error 1
make[1]: Leaving directory `/usr/src/asterisk/res’
make: *** [subdirs] Error

this was from the cdr_tds.c install using the following,

tar -zxvf freetds-0.62.4.tar.gz &&
cd freetds-0.62.4 &&
./configure --prefix=/usr --with-tdsver=7.0
make &&
make install

then

cd …/asterisk

make clean &&
make update &&a
make &&
make install

Can anyone advise or point me in the right direction, is it a distro issue, or, is there a preferable distro?

Many thanks in advance,

Paul